summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2021-07-09 12:47:38 -0500
committerTom Hochstein <tom.hochstein@nxp.com>2021-07-09 12:47:38 -0500
commit999f5d25a266d1d72c942e860fc218b736ddd9af (patch)
tree20d926e7022c7e3586d620ebc264779fcd7c23d5 /recipes-bsp/u-boot
parentee1b9a2fce9aa252b841b47ec1bc5afb2b1cfd70 (diff)
downloadmeta-freescale-999f5d25a266d1d72c942e860fc218b736ddd9af.tar.gz
u-boot-imx: Fix deploy bug for multiple UBOOT_CONFIG entries
A for-loop iterating over entries in UBOOT_CONFIG incorrectly uses the full UBOOT_CONFIG variable in a binary name when the name should be specific to the current entry. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2021.04.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx_2021.04.bb b/recipes-bsp/u-boot/u-boot-imx_2021.04.bb
index 4ce4e5d2..6a279a12 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2021.04.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2021.04.bb
@@ -19,7 +19,7 @@ do_deploy_append_mx8m() {
19 then 19 then
20 install -d ${DEPLOYDIR}/${BOOT_TOOLS} 20 install -d ${DEPLOYDIR}/${BOOT_TOOLS}
21 install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS} 21 install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
22 install -m 0777 ${B}/${config}/u-boot-nodtb.bin ${DEPLOYDIR}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${UBOOT_CONFIG} 22 install -m 0777 ${B}/${config}/u-boot-nodtb.bin ${DEPLOYDIR}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${type}
23 fi 23 fi
24 done 24 done
25 unset j 25 unset j