summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2016-07-16 00:35:46 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-07-22 11:34:12 -0300
commitc279b7647467cbc05e0375efed26c9fec453aee9 (patch)
tree5ae5fc7ad13bdd83d9875f9af2c5459440269dfb /recipes-bsp/u-boot
parenta51bae26b2e8cee1eba5b39fc83d360e5de1b55a (diff)
downloadmeta-freescale-c279b7647467cbc05e0375efed26c9fec453aee9.tar.gz
u-boot-qoriq: set LOCALVERSION to +fsl
SDK_VERSION defaults to nodistro.0 which is not expected in this recipe. Also adjust the location of some settings, no code change. Signed-off-by: Ting Liu <ting.liu@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb11
1 files changed, 5 insertions, 6 deletions
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb b/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb
index 63b53904..002066d8 100644
--- a/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb
+++ b/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb
@@ -1,5 +1,4 @@
1require recipes-bsp/u-boot/u-boot.inc 1require recipes-bsp/u-boot/u-boot.inc
2inherit fsl-u-boot-localversion
3 2
4DESCRIPTION = "U-Boot provided by Freescale with focus on QorIQ boards" 3DESCRIPTION = "U-Boot provided by Freescale with focus on QorIQ boards"
5PROVIDES += "u-boot" 4PROVIDES += "u-boot"
@@ -25,6 +24,8 @@ SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=${SRCBRANCH} \
25" 24"
26SRCREV = "a9b437f50e2051f8d42ec9e1a6df52de4bc00e1e" 25SRCREV = "a9b437f50e2051f8d42ec9e1a6df52de4bc00e1e"
27 26
27S = "${WORKDIR}/git"
28
28python () { 29python () {
29 if d.getVar("TCMODE", True) == "external-fsl": 30 if d.getVar("TCMODE", True) == "external-fsl":
30 return 31 return
@@ -43,13 +44,11 @@ python () {
43} 44}
44 45
45WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" 46WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
46
47LOCALVERSION = "${@d.getVar('SDK_VERSION', True).partition(' ')[0]}"
48
49S = "${WORKDIR}/git"
50
51EXTRA_OEMAKE = 'CROSS_COMPILE=${WRAP_TARGET_PREFIX} CC="${WRAP_TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"' 47EXTRA_OEMAKE = 'CROSS_COMPILE=${WRAP_TARGET_PREFIX} CC="${WRAP_TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
52 48
49inherit fsl-u-boot-localversion
50LOCALVERSION = "+fsl"
51
53do_compile_append_qoriq () { 52do_compile_append_qoriq () {
54 unset i j 53 unset i j
55 if [ -n "${UBOOT_CONFIG}" ];then 54 if [ -n "${UBOOT_CONFIG}" ];then