diff options
author | Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> | 2021-09-20 08:42:00 +0000 |
---|---|---|
committer | Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> | 2021-09-20 08:42:00 +0000 |
commit | 6880e0e3c6d212421e9aba1bb5b444be3f41be04 (patch) | |
tree | 3af951a70d3155e2b65c6978523c5f9191a06f4a /recipes-bsp/u-boot | |
parent | 325ad529187fb1309b0a889c5196c8df039aeea9 (diff) | |
download | meta-freescale-6880e0e3c6d212421e9aba1bb5b444be3f41be04.tar.gz |
u-boot-fslc: drop unused deploy task append
Recipe contains append to a deploy task, which is currently handled by
imx-boot-container class and is not needed in the recipe anymore.
Moreover, recipe compatibility does not include mx8m machine override,
which makes the deploy append block never to be included.
Remove the unused append block from recipe.
Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc_2021.07.bb | 42 |
1 files changed, 0 insertions, 42 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2021.07.bb b/recipes-bsp/u-boot/u-boot-fslc_2021.07.bb index 2e7bde38..fa219325 100644 --- a/recipes-bsp/u-boot/u-boot-fslc_2021.07.bb +++ b/recipes-bsp/u-boot/u-boot-fslc_2021.07.bb | |||
@@ -27,47 +27,5 @@ EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CPPFLAGS}" \ | |||
27 | HOSTLDFLAGS="${BUILD_LDFLAGS}" \ | 27 | HOSTLDFLAGS="${BUILD_LDFLAGS}" \ |
28 | HOSTSTRIP=true' | 28 | HOSTSTRIP=true' |
29 | 29 | ||
30 | # | ||
31 | # imx8m machines require additional deployment tasks to be | ||
32 | # carried out due to the fact that final boot image is constructed | ||
33 | # using imx-boot recipe. It produces a boot binary image, which is | ||
34 | # constructed from various binary components (u-boot with separate | ||
35 | # dtb, atf, DDR firmware and optional op-tee) into a single image | ||
36 | # using FIT format. This image is then parsed and loaded either via | ||
37 | # SPL directly (imx8mm), or using bootrom code (imx8mn and imx8mp). | ||
38 | # | ||
39 | # In order for imx-boot to construct the final binary boot image, | ||
40 | # it is required that the U-Boot dtb files are to be deployed into | ||
41 | # a location known by imx-boot so they could be picked up and | ||
42 | # inserted into the boot container. | ||
43 | # | ||
44 | # NOTE: This is only applicable to those derivatives of mx8m family, | ||
45 | # which did not adopt the boot container mechanism provided by U-Boot | ||
46 | # build system itself. U-Boot is capable of producing a result binary, | ||
47 | # which includes all those deployed pieces below, hence once derivative | ||
48 | # starts to use it - below append would not be necessary. | ||
49 | # Once all mx8m derivatives are migrated to use the 'flash.bin' boot | ||
50 | # container - this append can be dropped completely. | ||
51 | do_deploy:append:mx8m() { | ||
52 | # Deploy the mkimage, u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary | ||
53 | if [ -n "${UBOOT_CONFIG}" ]; then | ||
54 | for config in ${UBOOT_MACHINE}; do | ||
55 | i=$(expr $i + 1); | ||
56 | for type in ${UBOOT_CONFIG}; do | ||
57 | j=$(expr $j + 1); | ||
58 | if [ $j -eq $i ] | ||
59 | then | ||
60 | install -d ${DEPLOYDIR}/${BOOT_TOOLS} | ||
61 | install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS} | ||
62 | install -m 0777 ${B}/${config}/u-boot-nodtb.bin ${DEPLOYDIR}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${UBOOT_CONFIG} | ||
63 | fi | ||
64 | done | ||
65 | unset j | ||
66 | done | ||
67 | unset i | ||
68 | fi | ||
69 | } | ||
70 | |||
71 | |||
72 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 30 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
73 | COMPATIBLE_MACHINE = "(mxs|mx5|mx6|mx7|vf|use-mainline-bsp)" | 31 | COMPATIBLE_MACHINE = "(mxs|mx5|mx6|mx7|vf|use-mainline-bsp)" |