summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2018-01-26 14:33:20 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-01-26 16:48:49 -0200
commit2de13d78a1979136b2706930d2d6cca58f1ba479 (patch)
treea7f46df7db42fb4690628a88453df4ad1fb41e66 /recipes-bsp/u-boot
parent5561148debf43f87504eee6551b2410ab4f22083 (diff)
downloadmeta-freescale-2de13d78a1979136b2706930d2d6cca58f1ba479.tar.gz
classes/recipes: Convert SkipPackage -> SkipRecipe
The new name is much more consistent with what this actually means. We put the pieces in place to rename everything a while back but looks like we forgot to actually do it! Fix that now. Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq_2017.12.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2017.12.bb b/recipes-bsp/u-boot/u-boot-qoriq_2017.12.bb
index 93bdeef1..c24416d5 100644
--- a/recipes-bsp/u-boot/u-boot-qoriq_2017.12.bb
+++ b/recipes-bsp/u-boot/u-boot-qoriq_2017.12.bb
@@ -43,7 +43,7 @@ python () {
43 d.setVar("WRAP_TARGET_PREFIX", 'powerpc' + sys_multilib + '-') 43 d.setVar("WRAP_TARGET_PREFIX", 'powerpc' + sys_multilib + '-')
44 elif "fsl-lsch2-32b:" in arch: 44 elif "fsl-lsch2-32b:" in arch:
45 if not "lib64" in ml: 45 if not "lib64" in ml:
46 raise bb.parse.SkipPackage("Building the u-boot for this arch requires multilib to be enabled") 46 raise bb.parse.SkipRecipe("Building the u-boot for this arch requires multilib to be enabled")
47 sys_multilib = d.getVar('TARGET_VENDOR') + 'mllib64-linux' 47 sys_multilib = d.getVar('TARGET_VENDOR') + 'mllib64-linux'
48 sys_original = d.getVar('TARGET_VENDOR') + '-' + d.getVar('TARGET_OS') 48 sys_original = d.getVar('TARGET_VENDOR') + '-' + d.getVar('TARGET_OS')
49 workdir = d.getVar('WORKDIR').replace(sys_original,sys_multilib) 49 workdir = d.getVar('WORKDIR').replace(sys_original,sys_multilib)