summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2021-05-02 20:56:46 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2021-05-04 14:07:09 -0300
commite2eda5e9eaf4523f1134860fce4929d27c551469 (patch)
treecb1fc1a91dc841787f8c6449c7b4d8cee0e3e575 /recipes-bsp/u-boot
parent7462ae5636ebd8551350253d2bb1c3047431ba0d (diff)
downloadmeta-freescale-e2eda5e9eaf4523f1134860fce4929d27c551469.tar.gz
u-boot-fslc: upgrade to 2021.07-rc version
Upgrade U-Boot version to the current 2021.07-rc from upstream, this version of U-Boot has a better support for mx8m series than the 2021.04. Tree is synchronized up to commit 8ddaf94358 ("Merge tag 'dm-pull-29apr21' of https://source.denx.de/u-boot/custodians/u-boot-dm") fro mupstream repository. Following patches are submitted internally to the tree: ---- 40d646ab7f arm: imx: imx8mm: correct unrecognized fracpll frequency 97de0bfbf2 imx8mn: configs: add support for distro boot commands e64e0e19b4 imx8mp: configs: enable distro default features d57afdaab0 imx8mm: configs: enable distro default features 2d107f6d15 imx: iMX6: Define disconnect_from_pc function 560a81e9cb MLK-21854-2 imx: uuu: Update autoboot to run uuu or fastboot 81e786caa1 pico-imx6ul, pico-imx7d: Explain how to use eMMC user partition 2f7d3890b6 mx6sabre_common: Dynamically change the video output 6b4b7e030e mx6sabresd: Enable video interfaces in bootargs ---- Align DEPENDS with those present for OE-Core version of u-boot recipe. Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-common_2021.07.inc (renamed from recipes-bsp/u-boot/u-boot-fslc-common_2021.04.inc)8
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mfgtool_2021.07.bb (renamed from recipes-bsp/u-boot/u-boot-fslc-mfgtool_2021.04.bb)0
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mxsboot_2021.07.bb (renamed from recipes-bsp/u-boot/u-boot-fslc-mxsboot_2021.04.bb)0
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2021.07.bb (renamed from recipes-bsp/u-boot/u-boot-fslc_2021.04.bb)2
4 files changed, 5 insertions, 5 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-common_2021.04.inc b/recipes-bsp/u-boot/u-boot-fslc-common_2021.07.inc
index 05f3d951..46716a8c 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-common_2021.04.inc
+++ b/recipes-bsp/u-boot/u-boot-fslc-common_2021.07.inc
@@ -6,14 +6,14 @@ inherit fsl-u-boot-localversion
6LICENSE = "GPLv2+" 6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://Licenses/README;md5=5a7450c57ffe5ae63fd732446b988025" 7LIC_FILES_CHKSUM = "file://Licenses/README;md5=5a7450c57ffe5ae63fd732446b988025"
8 8
9DEPENDS += "bison-native" 9DEPENDS += "flex-native bison-native"
10 10
11SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}" 11SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}"
12 12
13SRCREV = "31cf6b483b580898c7387ed97e69304ea8cc7c96" 13SRCREV = "b047e1dcd20a2a767aa72aba8a040b16903f261f"
14SRCBRANCH = "2021.04+fslc" 14SRCBRANCH = "2021.07+fslc"
15 15
16PV = "v2021.04+git${SRCPV}" 16PV = "v2021.07+git${SRCPV}"
17 17
18S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
19B = "${WORKDIR}/build" 19B = "${WORKDIR}/build"
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mfgtool_2021.04.bb b/recipes-bsp/u-boot/u-boot-fslc-mfgtool_2021.07.bb
index 7f02746b..7f02746b 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-mfgtool_2021.04.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc-mfgtool_2021.07.bb
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2021.04.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2021.07.bb
index 2492f450..2492f450 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2021.04.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2021.07.bb
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2021.04.bb b/recipes-bsp/u-boot/u-boot-fslc_2021.07.bb
index 86620c44..4f97c722 100644
--- a/recipes-bsp/u-boot/u-boot-fslc_2021.04.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc_2021.07.bb
@@ -8,7 +8,7 @@ version, or because it is not applicable for upstreaming."
8 8
9inherit ${@oe.utils.ifelse(d.getVar('UBOOT_PROVIDES_BOOT_CONTAINER') == '1', 'imx-boot-container', '')} 9inherit ${@oe.utils.ifelse(d.getVar('UBOOT_PROVIDES_BOOT_CONTAINER') == '1', 'imx-boot-container', '')}
10 10
11DEPENDS += "bc-native dtc-native lzop-native" 11DEPENDS += "bc-native dtc-native python3-setuptools-native"
12 12
13# Location known to imx-boot component, where U-Boot artifacts 13# Location known to imx-boot component, where U-Boot artifacts
14# should be additionally deployed. 14# should be additionally deployed.