diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2020-12-11 19:28:05 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-12-11 19:37:54 -0300 |
commit | 720555512011bd000eae284b187108d11aad76ae (patch) | |
tree | f3d5667d27efa288b9b43e2f2d9e87b2c4ab0e9b /recipes-bsp/u-boot | |
parent | 3d1224371908cd842b6393241d696e2c65336568 (diff) | |
download | meta-freescale-720555512011bd000eae284b187108d11aad76ae.tar.gz |
u-boot-imx-tools: Rework the COMPATIBLE_MACHINE strategy
We need to avoid setting the COMPATIBLE_MACHINE when not using an i.MX
based machine, otherwise we end with multiple provides and cause
problems for outside machines.
To support both use-cases, and allow the use of u-boot-imx-tools, we set
the recipe as invalid for all use, except for 'use-mainline-bsp' and
'use-nxp-bsp' based machines.
Refs: #573.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Change-Id: I3b60828ce93c087a4774c71dbe62bab62bb6863d
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r-- | recipes-bsp/u-boot/u-boot-imx-tools_2020.04.bb | 9 |
1 files changed, 7 insertions, 2 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx-tools_2020.04.bb b/recipes-bsp/u-boot/u-boot-imx-tools_2020.04.bb index 12ac72e2..d1e9512c 100644 --- a/recipes-bsp/u-boot/u-boot-imx-tools_2020.04.bb +++ b/recipes-bsp/u-boot/u-boot-imx-tools_2020.04.bb | |||
@@ -6,5 +6,10 @@ PROVIDES_append_class-native = " u-boot-tools-native" | |||
6 | PROVIDES_append_class-nativesdk = " nativesdk-u-boot-tools" | 6 | PROVIDES_append_class-nativesdk = " nativesdk-u-boot-tools" |
7 | 7 | ||
8 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 8 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
9 | COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" | 9 | |
10 | COMPATIBLE_MACHINE_class-target = "(mx6|mx7|mx8)" | 10 | # Set recipe as incompatible by default |
11 | COMPATIBLE_MACHINE = "(^$)" | ||
12 | |||
13 | # Whitelist its use for i.MX based machines | ||
14 | COMPATIBLE_MACHINE_use-mainline-bsp = "(.)" | ||
15 | COMPATIBLE_MACHINE_use-nxp-bsp = "(.)" | ||