diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-08-02 11:01:05 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-08-12 10:08:24 -0700 |
commit | 59d36c9832702989bfcca8a5af29fb2dff01efcc (patch) | |
tree | b2b07d98cb22bc5241cde7403b6a15d99821318e /recipes-bsp/u-boot | |
parent | 72f59d35816cd2be6159013e4d96d03abf7f1c4b (diff) | |
download | meta-freescale-59d36c9832702989bfcca8a5af29fb2dff01efcc.tar.gz |
layer: Convert to new override syntax
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r-- | recipes-bsp/u-boot/libubootenv_%.bbappend | 4 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc-mfgtool_2021.07.bb | 2 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc-mxsboot_2021.07.bb | 8 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-fslc_2021.07.bb | 4 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-imx-mfgtool_2021.04.bb | 2 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-imx_2021.04.bb | 2 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-qoriq_2020.04.bb | 20 |
7 files changed, 21 insertions, 21 deletions
diff --git a/recipes-bsp/u-boot/libubootenv_%.bbappend b/recipes-bsp/u-boot/libubootenv_%.bbappend index 2633c344..619b510e 100644 --- a/recipes-bsp/u-boot/libubootenv_%.bbappend +++ b/recipes-bsp/u-boot/libubootenv_%.bbappend | |||
@@ -29,8 +29,8 @@ def fixup_uboot_config_dependency(d): | |||
29 | # | Signed-off-by: Ming Liu <liu.ming50@gmail.com> | 29 | # | Signed-off-by: Ming Liu <liu.ming50@gmail.com> |
30 | # | Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> | 30 | # | Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> |
31 | # `---- | 31 | # `---- |
32 | ubootmachine = d.getVar("UBOOT_MACHINE_pn-%s" % imx_default_bootloader) | 32 | ubootmachine = d.getVar("UBOOT_MACHINE:pn-%s" % imx_default_bootloader) |
33 | ubootconfig = (d.getVar("UBOOT_CONFIG_pn-%s" % imx_default_bootloader) or "").split() | 33 | ubootconfig = (d.getVar("UBOOT_CONFIG:pn-%s" % imx_default_bootloader) or "").split() |
34 | 34 | ||
35 | d.setVar("UBOOT_CONFIG", ubootconfig) | 35 | d.setVar("UBOOT_CONFIG", ubootconfig) |
36 | d.setVar("UBOOT_MACHINE", ubootmachine) | 36 | d.setVar("UBOOT_MACHINE", ubootmachine) |
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mfgtool_2021.07.bb b/recipes-bsp/u-boot/u-boot-fslc-mfgtool_2021.07.bb index 7f02746b..2e79166b 100644 --- a/recipes-bsp/u-boot/u-boot-fslc-mfgtool_2021.07.bb +++ b/recipes-bsp/u-boot/u-boot-fslc-mfgtool_2021.07.bb | |||
@@ -2,7 +2,7 @@ | |||
2 | # Copyright (C) 2014-2016 Freescale Semiconductor | 2 | # Copyright (C) 2014-2016 Freescale Semiconductor |
3 | # Copyright 2017-2019 NXP | 3 | # Copyright 2017-2019 NXP |
4 | 4 | ||
5 | FILESEXTRAPATHS_prepend := "${THISDIR}/u-boot-fslc:" | 5 | FILESEXTRAPATHS:prepend := "${THISDIR}/u-boot-fslc:" |
6 | 6 | ||
7 | require u-boot-fslc_${PV}.bb | 7 | require u-boot-fslc_${PV}.bb |
8 | require u-boot-mfgtool.inc | 8 | require u-boot-mfgtool.inc |
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2021.07.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2021.07.bb index 2492f450..a3a732ef 100644 --- a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2021.07.bb +++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2021.07.bb | |||
@@ -7,9 +7,9 @@ DEPENDS = "bison-native dtc openssl" | |||
7 | 7 | ||
8 | PROVIDES = "u-boot-mxsboot" | 8 | PROVIDES = "u-boot-mxsboot" |
9 | 9 | ||
10 | EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y' | 10 | EXTRA_OEMAKE:class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y' |
11 | EXTRA_OEMAKE_class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y' | 11 | EXTRA_OEMAKE:class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y' |
12 | EXTRA_OEMAKE_class-nativesdk = 'CROSS_COMPILE="${HOST_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y' | 12 | EXTRA_OEMAKE:class-nativesdk = 'CROSS_COMPILE="${HOST_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y' |
13 | 13 | ||
14 | do_compile () { | 14 | do_compile () { |
15 | oe_runmake -C ${S} O=${B} sandbox_defconfig | 15 | oe_runmake -C ${S} O=${B} sandbox_defconfig |
@@ -27,6 +27,6 @@ do_install () { | |||
27 | ln -sf uboot-mxsboot ${D}${bindir}/mxsboot | 27 | ln -sf uboot-mxsboot ${D}${bindir}/mxsboot |
28 | } | 28 | } |
29 | 29 | ||
30 | COMPATIBLE_MACHINE_class-target = "(mxs|mx5|mx6|mx7|vf|use-mainline-bsp)" | 30 | COMPATIBLE_MACHINE:class-target = "(mxs|mx5|mx6|mx7|vf|use-mainline-bsp)" |
31 | 31 | ||
32 | BBCLASSEXTEND = "native nativesdk" | 32 | BBCLASSEXTEND = "native nativesdk" |
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2021.07.bb b/recipes-bsp/u-boot/u-boot-fslc_2021.07.bb index 4f97c722..2e7bde38 100644 --- a/recipes-bsp/u-boot/u-boot-fslc_2021.07.bb +++ b/recipes-bsp/u-boot/u-boot-fslc_2021.07.bb | |||
@@ -12,7 +12,7 @@ DEPENDS += "bc-native dtc-native python3-setuptools-native" | |||
12 | 12 | ||
13 | # Location known to imx-boot component, where U-Boot artifacts | 13 | # Location known to imx-boot component, where U-Boot artifacts |
14 | # should be additionally deployed. | 14 | # should be additionally deployed. |
15 | # See below note above do_deploy_append_mx8m for the purpose of | 15 | # See below note above do_deploy:append:mx8m for the purpose of |
16 | # this delopyment location | 16 | # this delopyment location |
17 | BOOT_TOOLS = "imx-boot-tools" | 17 | BOOT_TOOLS = "imx-boot-tools" |
18 | 18 | ||
@@ -48,7 +48,7 @@ EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CPPFLAGS}" \ | |||
48 | # starts to use it - below append would not be necessary. | 48 | # starts to use it - below append would not be necessary. |
49 | # Once all mx8m derivatives are migrated to use the 'flash.bin' boot | 49 | # Once all mx8m derivatives are migrated to use the 'flash.bin' boot |
50 | # container - this append can be dropped completely. | 50 | # container - this append can be dropped completely. |
51 | do_deploy_append_mx8m() { | 51 | do_deploy:append:mx8m() { |
52 | # Deploy the mkimage, u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary | 52 | # Deploy the mkimage, u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary |
53 | if [ -n "${UBOOT_CONFIG}" ]; then | 53 | if [ -n "${UBOOT_CONFIG}" ]; then |
54 | for config in ${UBOOT_MACHINE}; do | 54 | for config in ${UBOOT_MACHINE}; do |
diff --git a/recipes-bsp/u-boot/u-boot-imx-mfgtool_2021.04.bb b/recipes-bsp/u-boot/u-boot-imx-mfgtool_2021.04.bb index 2b296c19..af502889 100644 --- a/recipes-bsp/u-boot/u-boot-imx-mfgtool_2021.04.bb +++ b/recipes-bsp/u-boot/u-boot-imx-mfgtool_2021.04.bb | |||
@@ -2,7 +2,7 @@ | |||
2 | # Copyright (C) 2014-2016 Freescale Semiconductor | 2 | # Copyright (C) 2014-2016 Freescale Semiconductor |
3 | # Copyright 2017-2019 NXP | 3 | # Copyright 2017-2019 NXP |
4 | 4 | ||
5 | FILESEXTRAPATHS_prepend := "${THISDIR}/u-boot-imx:" | 5 | FILESEXTRAPATHS:prepend := "${THISDIR}/u-boot-imx:" |
6 | 6 | ||
7 | require u-boot-imx_${PV}.bb | 7 | require u-boot-imx_${PV}.bb |
8 | require u-boot-mfgtool.inc | 8 | require u-boot-mfgtool.inc |
diff --git a/recipes-bsp/u-boot/u-boot-imx_2021.04.bb b/recipes-bsp/u-boot/u-boot-imx_2021.04.bb index 6a279a12..bb5809e2 100644 --- a/recipes-bsp/u-boot/u-boot-imx_2021.04.bb +++ b/recipes-bsp/u-boot/u-boot-imx_2021.04.bb | |||
@@ -7,7 +7,7 @@ require u-boot-imx-common_${PV}.inc | |||
7 | 7 | ||
8 | PROVIDES += "u-boot" | 8 | PROVIDES += "u-boot" |
9 | 9 | ||
10 | do_deploy_append_mx8m() { | 10 | do_deploy:append:mx8m() { |
11 | # Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary | 11 | # Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary |
12 | if [ -n "${UBOOT_CONFIG}" ] | 12 | if [ -n "${UBOOT_CONFIG}" ] |
13 | then | 13 | then |
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2020.04.bb b/recipes-bsp/u-boot/u-boot-qoriq_2020.04.bb index 57f27803..69b03de1 100644 --- a/recipes-bsp/u-boot/u-boot-qoriq_2020.04.bb +++ b/recipes-bsp/u-boot/u-boot-qoriq_2020.04.bb | |||
@@ -19,14 +19,14 @@ SRCREV= "f46a944f715f284aff1d42c009680ffe0be4058f" | |||
19 | 19 | ||
20 | S = "${WORKDIR}/git" | 20 | S = "${WORKDIR}/git" |
21 | B = "${WORKDIR}/build" | 21 | B = "${WORKDIR}/build" |
22 | PV_append = "+fslgit" | 22 | PV:append = "+fslgit" |
23 | LOCALVERSION = "+fsl" | 23 | LOCALVERSION = "+fsl" |
24 | 24 | ||
25 | INHIBIT_DEFAULT_DEPS = "1" | 25 | INHIBIT_DEFAULT_DEPS = "1" |
26 | DEPENDS = "libgcc virtual/${TARGET_PREFIX}gcc bison-native bc-native swig-native python3-native" | 26 | DEPENDS = "libgcc virtual/${TARGET_PREFIX}gcc bison-native bc-native swig-native python3-native" |
27 | DEPENDS_append_qoriq-arm64 = " dtc-native" | 27 | DEPENDS:append:qoriq-arm64 = " dtc-native" |
28 | DEPENDS_append_qoriq-arm = " dtc-native" | 28 | DEPENDS:append:qoriq-arm = " dtc-native" |
29 | DEPENDS_append_qoriq-ppc = " boot-format-native" | 29 | DEPENDS:append:qoriq-ppc = " boot-format-native" |
30 | 30 | ||
31 | python () { | 31 | python () { |
32 | if d.getVar("TCMODE") == "external-fsl": | 32 | if d.getVar("TCMODE") == "external-fsl": |
@@ -41,8 +41,8 @@ python () { | |||
41 | sys_multilib = d.getVar('TARGET_VENDOR') + 'mllib32-linux' | 41 | sys_multilib = d.getVar('TARGET_VENDOR') + 'mllib32-linux' |
42 | sys_original = d.getVar('TARGET_VENDOR') + '-' + d.getVar('TARGET_OS') | 42 | sys_original = d.getVar('TARGET_VENDOR') + '-' + d.getVar('TARGET_OS') |
43 | workdir = d.getVar('WORKDIR') | 43 | workdir = d.getVar('WORKDIR') |
44 | d.setVar('DEPENDS_append', ' lib32-gcc-cross-powerpc lib32-libgcc') | 44 | d.setVar('DEPENDS:append', ' lib32-gcc-cross-powerpc lib32-libgcc') |
45 | d.setVar('PATH_append', ':' + d.getVar('STAGING_BINDIR_NATIVE') + '/powerpc' + sys_multilib) | 45 | d.setVar('PATH:append', ':' + d.getVar('STAGING_BINDIR_NATIVE') + '/powerpc' + sys_multilib) |
46 | d.setVar('TOOLCHAIN_OPTIONS', '--sysroot=' + workdir + '/lib32-recipe-sysroot') | 46 | d.setVar('TOOLCHAIN_OPTIONS', '--sysroot=' + workdir + '/lib32-recipe-sysroot') |
47 | d.setVar("WRAP_TARGET_PREFIX", 'powerpc' + sys_multilib + '-') | 47 | d.setVar("WRAP_TARGET_PREFIX", 'powerpc' + sys_multilib + '-') |
48 | elif "fsl-lsch2-32b:" in arch: | 48 | elif "fsl-lsch2-32b:" in arch: |
@@ -51,8 +51,8 @@ python () { | |||
51 | sys_multilib = d.getVar('TARGET_VENDOR') + 'mllib64-linux' | 51 | sys_multilib = d.getVar('TARGET_VENDOR') + 'mllib64-linux' |
52 | sys_original = d.getVar('TARGET_VENDOR') + '-' + d.getVar('TARGET_OS') | 52 | sys_original = d.getVar('TARGET_VENDOR') + '-' + d.getVar('TARGET_OS') |
53 | workdir = d.getVar('WORKDIR') | 53 | workdir = d.getVar('WORKDIR') |
54 | d.setVar('DEPENDS_append', ' lib64-gcc-cross-aarch64 lib64-libgcc') | 54 | d.setVar('DEPENDS:append', ' lib64-gcc-cross-aarch64 lib64-libgcc') |
55 | d.setVar('PATH_append', ':' + d.getVar('STAGING_BINDIR_NATIVE') + '/aarch64' + sys_multilib) | 55 | d.setVar('PATH:append', ':' + d.getVar('STAGING_BINDIR_NATIVE') + '/aarch64' + sys_multilib) |
56 | d.setVar('TOOLCHAIN_OPTIONS', '--sysroot=' + workdir + '/lib64-recipe-sysroot') | 56 | d.setVar('TOOLCHAIN_OPTIONS', '--sysroot=' + workdir + '/lib64-recipe-sysroot') |
57 | d.setVar("WRAP_TARGET_PREFIX", 'aarch64' + sys_multilib + '-') | 57 | d.setVar("WRAP_TARGET_PREFIX", 'aarch64' + sys_multilib + '-') |
58 | } | 58 | } |
@@ -66,7 +66,7 @@ EXTRA_OEMAKE = 'CROSS_COMPILE=${WRAP_TARGET_PREFIX} CC="${WRAP_TARGET_PREFIX}gcc | |||
66 | EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}"' | 66 | EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}"' |
67 | EXTRA_OEMAKE += 'STAGING_INCDIR=${STAGING_INCDIR_NATIVE} STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE}' | 67 | EXTRA_OEMAKE += 'STAGING_INCDIR=${STAGING_INCDIR_NATIVE} STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE}' |
68 | 68 | ||
69 | do_compile_append_qoriq() { | 69 | do_compile:append:qoriq() { |
70 | unset i j k | 70 | unset i j k |
71 | for config in ${UBOOT_MACHINE}; do | 71 | for config in ${UBOOT_MACHINE}; do |
72 | i=`expr $i + 1`; | 72 | i=`expr $i + 1`; |
@@ -94,5 +94,5 @@ do_compile_append_qoriq() { | |||
94 | 94 | ||
95 | 95 | ||
96 | PACKAGES += "${PN}-images" | 96 | PACKAGES += "${PN}-images" |
97 | FILES_${PN}-images += "/boot" | 97 | FILES:${PN}-images += "/boot" |
98 | COMPATIBLE_MACHINE = "(qoriq)" | 98 | COMPATIBLE_MACHINE = "(qoriq)" |