summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2017-10-04 10:31:46 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2017-10-04 14:36:00 -0300
commit2bb4bb7c936f2654a6348da90693ea3125fb3415 (patch)
treeaae97804ff42972ad428d48d0c48c979038aa7d1 /recipes-bsp/u-boot
parent2c0bd2e821e51bd175fb5591a9a20ed214fea0e3 (diff)
downloadmeta-freescale-2bb4bb7c936f2654a6348da90693ea3125fb3415.tar.gz
u-boot-fslc: Create u-boot-fslc-common include file
Use a common file to make easier update, maintain and create others U-Boot recipes like U-Boot fw-utils. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-common_2017.09.inc (renamed from recipes-bsp/u-boot/u-boot-fslc.inc)16
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb17
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2017.09.bb12
3 files changed, 17 insertions, 28 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc.inc b/recipes-bsp/u-boot/u-boot-fslc-common_2017.09.inc
index 39ecc2cd..6173cda0 100644
--- a/recipes-bsp/u-boot/u-boot-fslc.inc
+++ b/recipes-bsp/u-boot/u-boot-fslc-common_2017.09.inc
@@ -1,4 +1,4 @@
1# Copyright (C) 2012-2016 O.S. Systems Software LTDA. 1# Copyright (C) 2012-2017 O.S. Systems Software LTDA.
2# Released under the MIT license (see COPYING.MIT for the terms) 2# Released under the MIT license (see COPYING.MIT for the terms)
3 3
4require recipes-bsp/u-boot/u-boot.inc 4require recipes-bsp/u-boot/u-boot.inc
@@ -16,19 +16,13 @@ COMPATIBLE_MACHINE = "(mxs|mx5|mx6|mx7|vf|use-mainline-bsp)"
16DEPENDS_append = " dtc-native" 16DEPENDS_append = " dtc-native"
17DEPENDS_mxs += "elftosb-native openssl-native" 17DEPENDS_mxs += "elftosb-native openssl-native"
18 18
19PROVIDES += "u-boot" 19SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}"
20 20
21SRCBRANCH ??= "master" 21SRCREV = "9f164a1a01fceb53fc88ad474a5cda70f1c486c2"
22SRCBRANCH = "2017.09+fslc"
22 23
23SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}" 24PV = "v2017.09+git${SRCPV}"
24 25
25S = "${WORKDIR}/git" 26S = "${WORKDIR}/git"
26 27
27# FIXME: Allow linking of 'tools' binaries with native libraries
28# used for generating the boot logo and other tools used
29# during the build process.
30EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CPPFLAGS}" \
31 HOSTLDFLAGS="${BUILD_LDFLAGS}" \
32 HOSTSTRIP=true'
33
34PACKAGE_ARCH = "${MACHINE_ARCH}" 28PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb
index 0bbcd084..b67a53ce 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb
@@ -1,20 +1,11 @@
1require u-boot-fslc-common_${PV}.inc
2
1DESCRIPTION = "U-boot bootloader mxsboot tool" 3DESCRIPTION = "U-boot bootloader mxsboot tool"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
4SECTION = "bootloader" 4SECTION = "bootloader"
5DEPENDS = "openssl"
6PROVIDES = "u-boot-mxsboot"
7
8PV = "v2017.09+git${SRCPV}"
9 5
10SRCREV = "9f164a1a01fceb53fc88ad474a5cda70f1c486c2" 6DEPENDS_append = " openssl"
11SRCBRANCH = "2017.09+fslc"
12 7
13SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}" 8PROVIDES = "u-boot-mxsboot"
14
15S = "${WORKDIR}/git"
16
17inherit fsl-u-boot-localversion
18 9
19EXTRA_OEMAKE = 'HOSTCC="${CC} ${CPPFLAGS}" HOSTLDFLAGS="-L${libdir} -L${base_libdir}" HOSTSTRIP=true CONFIG_MX28=y' 10EXTRA_OEMAKE = 'HOSTCC="${CC} ${CPPFLAGS}" HOSTLDFLAGS="-L${libdir} -L${base_libdir}" HOSTSTRIP=true CONFIG_MX28=y'
20 11
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2017.09.bb b/recipes-bsp/u-boot/u-boot-fslc_2017.09.bb
index b3fd47a6..3aff2fa7 100644
--- a/recipes-bsp/u-boot/u-boot-fslc_2017.09.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc_2017.09.bb
@@ -1,6 +1,10 @@
1include u-boot-fslc.inc 1require u-boot-fslc-common_${PV}.inc
2 2
3PV = "v2017.09+git${SRCPV}" 3PROVIDES += "u-boot"
4 4
5SRCREV = "9f164a1a01fceb53fc88ad474a5cda70f1c486c2" 5# FIXME: Allow linking of 'tools' binaries with native libraries
6SRCBRANCH = "2017.09+fslc" 6# used for generating the boot logo and other tools used
7# during the build process.
8EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CPPFLAGS}" \
9 HOSTLDFLAGS="${BUILD_LDFLAGS}" \
10 HOSTSTRIP=true'