summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2019-01-17 14:29:17 +0000
committerAndré Draszik <andre.draszik@jci.com>2019-01-17 14:29:17 +0000
commit74df05a7f0fd698cbbe65b9bf925f186891426ca (patch)
tree169665d86e12f2aa2d6df71a856c1893267972d7 /recipes-bsp/u-boot
parent9704df97f08cf5895e2f5bcfb33f1a53d10c7704 (diff)
downloadmeta-freescale-74df05a7f0fd698cbbe65b9bf925f186891426ca.tar.gz
remove True option to getVar calls
getVar() has been defaulting to expanding by default for a long time (2016), thus remove the True option from getVar() calls with a regex search and replace. Search & replace made using the following command: sed -e 's|\(d\.getVar \?\)( \?\([^,()]*\), \?True)|\1(\2)|g' \ -i $(git grep -E 'getVar ?\( ?([^,()]*), ?True\)' \ | cut -d':' -f1 \ | sort -u) Signed-off-by: André Draszik <andre.draszik@jci.com>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq_2018.09.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2018.09.bb b/recipes-bsp/u-boot/u-boot-qoriq_2018.09.bb
index 8438134d..f48dc81f 100644
--- a/recipes-bsp/u-boot/u-boot-qoriq_2018.09.bb
+++ b/recipes-bsp/u-boot/u-boot-qoriq_2018.09.bb
@@ -11,11 +11,11 @@ DEPENDS_append_qoriq-arm = " change-file-endianess-native dtc-native tcl-native"
11DEPENDS_append_qoriq-ppc = " boot-format-native" 11DEPENDS_append_qoriq-ppc = " boot-format-native"
12 12
13python () { 13python () {
14 if d.getVar("TCMODE", True) == "external-fsl": 14 if d.getVar("TCMODE") == "external-fsl":
15 return 15 return
16 16
17 ml = d.getVar("MULTILIB_VARIANTS", True) 17 ml = d.getVar("MULTILIB_VARIANTS")
18 arch = d.getVar("OVERRIDES", True) 18 arch = d.getVar("OVERRIDES")
19 19
20 if "e5500-64b:" in arch or "e6500-64b:" in arch: 20 if "e5500-64b:" in arch or "e6500-64b:" in arch:
21 if not "lib32" in ml: 21 if not "lib32" in ml: