summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-01-19 19:29:24 -0300
committerGitHub <noreply@github.com>2022-01-19 19:29:24 -0300
commit63073229b904c0c662cb75116a8c4dfaf03da1f4 (patch)
tree0977606ae3a29bfc6844c0d285a1b23ddc446abb /recipes-bsp/u-boot
parent1041425ee15140674d3fd721c6c85c5f59f5728b (diff)
parent9fa3004dab003fd616fea89c5a0baf6c48ce5a72 (diff)
downloadmeta-freescale-63073229b904c0c662cb75116a8c4dfaf03da1f4.tar.gz
Merge pull request #954 from thochstein/recipes-bsp
u-boot-imx and recipes-bsp for 5.10.72-2.2.0
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot-imx-common_2021.04.inc6
-rw-r--r--recipes-bsp/u-boot/u-boot-imx-mfgtool_2021.04.bb4
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2021.04.bb9
3 files changed, 15 insertions, 4 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx-common_2021.04.inc b/recipes-bsp/u-boot/u-boot-imx-common_2021.04.inc
index 2abcac9b..f82f7b67 100644
--- a/recipes-bsp/u-boot/u-boot-imx-common_2021.04.inc
+++ b/recipes-bsp/u-boot/u-boot-imx-common_2021.04.inc
@@ -5,7 +5,8 @@ LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a
5 5
6SRCBRANCH = "lf_v2021.04" 6SRCBRANCH = "lf_v2021.04"
7SRC_URI = "git://source.codeaurora.org/external/imx/uboot-imx.git;protocol=https;branch=${SRCBRANCH}" 7SRC_URI = "git://source.codeaurora.org/external/imx/uboot-imx.git;protocol=https;branch=${SRCBRANCH}"
8SRCREV = "3463140881c523e248d2fcb6bfc9ed25c0db93bd" 8SRCREV = "263b27e076a0f6e5dcc80227a235f0af73718342"
9LOCALVERSION ?= "-imx_v2021.04_5.10.72_2.2.0"
9 10
10DEPENDS += "flex-native bison-native bc-native dtc-native" 11DEPENDS += "flex-native bison-native bc-native dtc-native"
11 12
@@ -14,7 +15,4 @@ B = "${WORKDIR}/build"
14 15
15inherit fsl-u-boot-localversion 16inherit fsl-u-boot-localversion
16 17
17LOCALVERSION ?= "-imx_v2021.04_5.10.35_2.0.0"
18
19BOOT_TOOLS = "imx-boot-tools" 18BOOT_TOOLS = "imx-boot-tools"
20
diff --git a/recipes-bsp/u-boot/u-boot-imx-mfgtool_2021.04.bb b/recipes-bsp/u-boot/u-boot-imx-mfgtool_2021.04.bb
index af502889..5443ceac 100644
--- a/recipes-bsp/u-boot/u-boot-imx-mfgtool_2021.04.bb
+++ b/recipes-bsp/u-boot/u-boot-imx-mfgtool_2021.04.bb
@@ -6,3 +6,7 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/u-boot-imx:"
6 6
7require u-boot-imx_${PV}.bb 7require u-boot-imx_${PV}.bb
8require u-boot-mfgtool.inc 8require u-boot-mfgtool.inc
9
10UUU_BOOTLOADER_TAGGED = ""
11UUU_BOOTLOADER_TAGGED:mx6 = "u-boot-mfgtool-tagged.${UBOOT_SUFFIX}"
12UUU_BOOTLOADER_TAGGED:mx7 = "u-boot-mfgtool-tagged.${UBOOT_SUFFIX}"
diff --git a/recipes-bsp/u-boot/u-boot-imx_2021.04.bb b/recipes-bsp/u-boot/u-boot-imx_2021.04.bb
index bb5809e2..96552eef 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2021.04.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2021.04.bb
@@ -7,6 +7,15 @@ require u-boot-imx-common_${PV}.inc
7 7
8PROVIDES += "u-boot" 8PROVIDES += "u-boot"
9 9
10inherit uuu_bootloader_tag
11
12UUU_BOOTLOADER = ""
13UUU_BOOTLOADER:mx6 = "${UBOOT_BINARY}"
14UUU_BOOTLOADER:mx7 = "${UBOOT_BINARY}"
15UUU_BOOTLOADER_TAGGED = ""
16UUU_BOOTLOADER_TAGGED:mx6 = "u-boot-tagged.${UBOOT_SUFFIX}"
17UUU_BOOTLOADER_TAGGED:mx7 = "u-boot-tagged.${UBOOT_SUFFIX}"
18
10do_deploy:append:mx8m() { 19do_deploy:append:mx8m() {
11 # Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary 20 # Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
12 if [ -n "${UBOOT_CONFIG}" ] 21 if [ -n "${UBOOT_CONFIG}" ]