summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2016-07-16 00:35:44 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-07-22 11:34:12 -0300
commit1e4a779ce49db1940f4585d97feb4f02bfa8c4f1 (patch)
tree2065be6c064fb8a6c2b8e9973efc739cbce57aab /recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb
parent0ff0e401d09fb9e063611d32117d3507fd135599 (diff)
downloadmeta-freescale-1e4a779ce49db1940f4585d97feb4f02bfa8c4f1.tar.gz
u-boot-qoriq: remove duplicate settings with oe-core
Signed-off-by: Ting Liu <ting.liu@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb11
1 files changed, 2 insertions, 9 deletions
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb b/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb
index cfb345ed..3a1f483c 100644
--- a/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb
+++ b/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb
@@ -1,10 +1,8 @@
1require recipes-bsp/u-boot/u-boot.inc 1require recipes-bsp/u-boot/u-boot.inc
2inherit fsl-u-boot-localversion 2inherit fsl-u-boot-localversion
3 3
4DESCRIPTION = "U-boot provided by Freescale with focus on QorIQ boards" 4DESCRIPTION = "U-Boot provided by Freescale with focus on QorIQ boards"
5HOMEPAGE = "http://u-boot.sf.net" 5PROVIDES += "u-boot"
6SECTION = "bootloaders"
7PROVIDES = "virtual/bootloader u-boot"
8LICENSE = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1" 6LICENSE = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1"
9LIC_FILES_CHKSUM = " \ 7LIC_FILES_CHKSUM = " \
10 file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ 8 file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
@@ -20,8 +18,6 @@ DEPENDS = "libgcc virtual/${TARGET_PREFIX}gcc"
20DEPENDS_append_qoriq-arm = " change-file-endianess-native dtc-native tcl-native" 18DEPENDS_append_qoriq-arm = " change-file-endianess-native dtc-native tcl-native"
21DEPENDS_append_qoriq-ppc = " boot-format-native" 19DEPENDS_append_qoriq-ppc = " boot-format-native"
22 20
23inherit deploy
24
25SRCBRANCH = "sdk-v2.0.x" 21SRCBRANCH = "sdk-v2.0.x"
26SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=${SRCBRANCH} \ 22SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=${SRCBRANCH} \
27 file://fix-build-error-under-gcc6.patch \ 23 file://fix-build-error-under-gcc6.patch \
@@ -47,8 +43,6 @@ python () {
47 43
48WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" 44WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
49 45
50PACKAGE_ARCH = "${MACHINE_ARCH}"
51
52LOCALVERSION = "${@d.getVar('SDK_VERSION', True).partition(' ')[0]}" 46LOCALVERSION = "${@d.getVar('SDK_VERSION', True).partition(' ')[0]}"
53 47
54S = "${WORKDIR}/git" 48S = "${WORKDIR}/git"
@@ -84,5 +78,4 @@ do_compile_append_qoriq () {
84 78
85PACKAGES += "${PN}-images" 79PACKAGES += "${PN}-images"
86FILES_${PN}-images += "/boot" 80FILES_${PN}-images += "/boot"
87
88COMPATIBLE_MACHINE = "(qoriq)" 81COMPATIBLE_MACHINE = "(qoriq)"