summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-imx_2021.04.bb
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-01-13 17:56:08 -0600
committerTom Hochstein <tom.hochstein@nxp.com>2022-01-19 15:50:12 -0600
commit92acf99a6124df0d2e10bf10f296962ab9383ba1 (patch)
treedc2e1db48c353f686c25aaa7197b713ae6448c04 /recipes-bsp/u-boot/u-boot-imx_2021.04.bb
parent1f270dc776dc70856d645da5cdf1096edf2f369e (diff)
downloadmeta-freescale-92acf99a6124df0d2e10bf10f296962ab9383ba1.tar.gz
imx-boot,u-boot-imx: Add bootloader image size to SD card image
Append a tag to the bootloader image used in the SD card image. The tag contains the size of the bootloader image so UUU can easily find the end of the bootloader in the SD card image. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-imx_2021.04.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2021.04.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx_2021.04.bb b/recipes-bsp/u-boot/u-boot-imx_2021.04.bb
index bb5809e2..96552eef 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2021.04.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2021.04.bb
@@ -7,6 +7,15 @@ require u-boot-imx-common_${PV}.inc
7 7
8PROVIDES += "u-boot" 8PROVIDES += "u-boot"
9 9
10inherit uuu_bootloader_tag
11
12UUU_BOOTLOADER = ""
13UUU_BOOTLOADER:mx6 = "${UBOOT_BINARY}"
14UUU_BOOTLOADER:mx7 = "${UBOOT_BINARY}"
15UUU_BOOTLOADER_TAGGED = ""
16UUU_BOOTLOADER_TAGGED:mx6 = "u-boot-tagged.${UBOOT_SUFFIX}"
17UUU_BOOTLOADER_TAGGED:mx7 = "u-boot-tagged.${UBOOT_SUFFIX}"
18
10do_deploy:append:mx8m() { 19do_deploy:append:mx8m() {
11 # Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary 20 # Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
12 if [ -n "${UBOOT_CONFIG}" ] 21 if [ -n "${UBOOT_CONFIG}" ]