summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-imx_2018.03.bb
diff options
context:
space:
mode:
authorMihai Lindner <mihai.lindner@nxp.com>2019-05-14 12:36:55 +0300
committerOtavio Salvador <otavio@ossystems.com.br>2019-05-15 11:18:32 -0300
commitad02a20608b0bbb184fe633bd8a50c785d2002cd (patch)
treed89b84f536ee1470e01a824d22cb69a12b52184c /recipes-bsp/u-boot/u-boot-imx_2018.03.bb
parent3dc8f2fe59866395681e1aa0565b1d98ca27043e (diff)
downloadmeta-freescale-ad02a20608b0bbb184fe633bd8a50c785d2002cd.tar.gz
u-boot-imx: Upgrade version 2017.03 to 2018.03
Upgrade version to 2018.03 from branch imx_v2018.03_4.14.98_2.0.0_ga. Drop usage of dtc-145 binary, pulled by the class with the same name, which was a workaround for older u-boot versions. Signed-off-by: Mihai Lindner <mihai.lindner@nxp.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-imx_2018.03.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2018.03.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx_2018.03.bb b/recipes-bsp/u-boot/u-boot-imx_2018.03.bb
new file mode 100644
index 00000000..fcd34136
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-imx_2018.03.bb
@@ -0,0 +1,48 @@
1# Copyright (C) 2013-2016 Freescale Semiconductor
2# Copyright 2018 (C) O.S. Systems Software LTDA.
3# Copyright 2017-2019 NXP
4
5DESCRIPTION = "i.MX U-Boot suppporting i.MX reference boards."
6require recipes-bsp/u-boot/u-boot.inc
7
8PROVIDES += "u-boot"
9
10LICENSE = "GPLv2+"
11LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
12
13SRCBRANCH = "imx_v2018.03_4.14.98_2.0.0_ga"
14SRC_URI = "git://source.codeaurora.org/external/imx/uboot-imx.git;protocol=https;branch=${SRCBRANCH}"
15SRCREV = "0d6d8807793e74402e23772062469aeb4808dd48"
16
17S = "${WORKDIR}/git"
18
19inherit fsl-u-boot-localversion
20
21LOCALVERSION ?= "-${SRCBRANCH}"
22
23BOOT_TOOLS = "imx-boot-tools"
24
25do_deploy_append_mx8m() {
26 # Deploy the mkimage, u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
27 if [ -n "${UBOOT_CONFIG}" ]
28 then
29 for config in ${UBOOT_MACHINE}; do
30 i=$(expr $i + 1);
31 for type in ${UBOOT_CONFIG}; do
32 j=$(expr $j + 1);
33 if [ $j -eq $i ]
34 then
35 install -d ${DEPLOYDIR}/${BOOT_TOOLS}
36 install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
37 install -m 0777 ${B}/${config}/tools/mkimage ${DEPLOYDIR}/${BOOT_TOOLS}/mkimage_uboot
38 install -m 0777 ${B}/${config}/u-boot-nodtb.bin ${DEPLOYDIR}/${BOOT_TOOLS}/u-boot-nodtb.bin
39 fi
40 done
41 unset j
42 done
43 unset i
44 fi
45}
46
47PACKAGE_ARCH = "${MACHINE_ARCH}"
48COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"