summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-fslc_2022.07.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-07-23 17:23:26 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2022-07-28 14:19:21 -0300
commitfc38a34b27980871c0c828fc87404d41e482c1b9 (patch)
treed050dc0182acd7b6f406fc06bc5f0f1053016b44 /recipes-bsp/u-boot/u-boot-fslc_2022.07.bb
parent388fd2ec200fb71fcec3c1fd7443b337cddd00d5 (diff)
downloadmeta-freescale-fc38a34b27980871c0c828fc87404d41e482c1b9.tar.gz
u-boot-fslc: 2022.04 -> 2022.07
One side change is the removal of the 'v' prefix in PV so we align with the common pattern of the u-boot recipes used in OE world. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-fslc_2022.07.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2022.07.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2022.07.bb b/recipes-bsp/u-boot/u-boot-fslc_2022.07.bb
new file mode 100644
index 00000000..de6d22d0
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fslc_2022.07.bb
@@ -0,0 +1,31 @@
1require recipes-bsp/u-boot/u-boot.inc
2require u-boot-fslc-common_${PV}.inc
3
4DESCRIPTION = "U-Boot based on mainline U-Boot used by FSL Community BSP in \
5order to provide support for some backported features and fixes, or because it \
6was submitted for revision and it takes some time to become part of a stable \
7version, or because it is not applicable for upstreaming."
8
9inherit ${@oe.utils.ifelse(d.getVar('UBOOT_PROVIDES_BOOT_CONTAINER') == '1', 'imx-boot-container', '')}
10
11DEPENDS += "bc-native dtc-native python3-setuptools-native"
12
13# Location known to imx-boot component, where U-Boot artifacts
14# should be additionally deployed.
15# See below note above do_deploy:append:mx8m-nxp-bsp for the purpose of
16# this delopyment location
17BOOT_TOOLS = "imx-boot-tools"
18
19PROVIDES += "u-boot"
20
21B = "${WORKDIR}/build"
22
23# FIXME: Allow linking of 'tools' binaries with native libraries
24# used for generating the boot logo and other tools used
25# during the build process.
26EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CPPFLAGS}" \
27 HOSTLDFLAGS="${BUILD_LDFLAGS}" \
28 HOSTSTRIP=true'
29
30PACKAGE_ARCH = "${MACHINE_ARCH}"
31COMPATIBLE_MACHINE = "(imx-generic-bsp)"