summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-fslc_2022.04.bb
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2022-04-05 19:13:14 +0000
committerAndrey Zhizhikin <andrey.z@gmail.com>2022-04-05 19:13:14 +0000
commit2daf76073d1080091520dcf391aa9dfc6bc06a10 (patch)
tree1cb6b37ac80587198a4bd2f5cd60bd08e7902df5 /recipes-bsp/u-boot/u-boot-fslc_2022.04.bb
parent7bf86e38cd3670076f9c0a7cff952e62da2c1db4 (diff)
downloadmeta-freescale-2daf76073d1080091520dcf391aa9dfc6bc06a10.tar.gz
u-boot-fslc: upgrade to v2022.04+fslc
U-Boot fork has been updated to include new version v2022.04 from upstream. Following commits were ported from 2022.01+fslc revision: ---- f885198273 imx: iMX6: Define disconnect_from_pc function 1667c942d0 MLK-21854-2 imx: uuu: Update autoboot to run uuu or fastboot c7805ae3cf pico-imx6ul, pico-imx7d: Explain how to use eMMC user partition 92268e6c2a mx6sabre_common: Dynamically change the video output f66f12923e mx6sabresd: Enable video interfaces in bootargs ---- Update U-Boot recipe versions and point to new revision. Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-fslc_2022.04.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2022.04.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2022.04.bb b/recipes-bsp/u-boot/u-boot-fslc_2022.04.bb
new file mode 100644
index 00000000..ec5298b6
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fslc_2022.04.bb
@@ -0,0 +1,31 @@
1require recipes-bsp/u-boot/u-boot.inc
2require u-boot-fslc-common_${PV}.inc
3
4DESCRIPTION = "U-Boot based on mainline U-Boot used by FSL Community BSP in \
5order to provide support for some backported features and fixes, or because it \
6was submitted for revision and it takes some time to become part of a stable \
7version, or because it is not applicable for upstreaming."
8
9inherit ${@oe.utils.ifelse(d.getVar('UBOOT_PROVIDES_BOOT_CONTAINER') == '1', 'imx-boot-container', '')}
10
11DEPENDS += "bc-native dtc-native python3-setuptools-native lzop-native"
12
13# Location known to imx-boot component, where U-Boot artifacts
14# should be additionally deployed.
15# See below note above do_deploy:append:mx8m-nxp-bsp for the purpose of
16# this delopyment location
17BOOT_TOOLS = "imx-boot-tools"
18
19PROVIDES += "u-boot"
20
21B = "${WORKDIR}/build"
22
23# FIXME: Allow linking of 'tools' binaries with native libraries
24# used for generating the boot logo and other tools used
25# during the build process.
26EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CPPFLAGS}" \
27 HOSTLDFLAGS="${BUILD_LDFLAGS}" \
28 HOSTSTRIP=true'
29
30PACKAGE_ARCH = "${MACHINE_ARCH}"
31COMPATIBLE_MACHINE = "(imx-generic-bsp)"