summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-fslc_2022.01.bb
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2022-01-17 16:36:42 +0000
committerAndrey Zhizhikin <andrey.z@gmail.com>2022-01-18 12:59:16 +0000
commita5cf92c3c35ce1fea695c36320fe72cdf102693f (patch)
tree154c5d74ca595b33b9fc226b873acfe457a54fbb /recipes-bsp/u-boot/u-boot-fslc_2022.01.bb
parentedb9ede43de3e70c4fea79bf4254d3ff550741a8 (diff)
downloadmeta-freescale-a5cf92c3c35ce1fea695c36320fe72cdf102693f.tar.gz
u-boot-fslc: upgrade to v2022.01+fslc
U-Boot fork has been updated to include new version v2022.01 from upstream. Following commits were ported from 2021.07+fslc revision: ---- e2b8a409f3 imx: iMX6: Define disconnect_from_pc function 708efb65a3 MLK-21854-2 imx: uuu: Update autoboot to run uuu or fastboot c51871146b pico-imx6ul, pico-imx7d: Explain how to use eMMC user partition 9033bca081 mx6sabre_common: Dynamically change the video output 4b3275b77f mx6sabresd: Enable video interfaces in bootargs ---- Following new commits are added to this revision: ---- 18bb53aebf imx8mn-ddr4-evk: generate single bootable image 125754edb5 imx8mq_evk: configs: add/cleanup variables for distro boot ---- Update U-Boot recipe versions and point to new revision. Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-fslc_2022.01.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2022.01.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2022.01.bb b/recipes-bsp/u-boot/u-boot-fslc_2022.01.bb
new file mode 100644
index 00000000..21989ae5
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fslc_2022.01.bb
@@ -0,0 +1,31 @@
1require recipes-bsp/u-boot/u-boot.inc
2require u-boot-fslc-common_${PV}.inc
3
4DESCRIPTION = "U-Boot based on mainline U-Boot used by FSL Community BSP in \
5order to provide support for some backported features and fixes, or because it \
6was submitted for revision and it takes some time to become part of a stable \
7version, or because it is not applicable for upstreaming."
8
9inherit ${@oe.utils.ifelse(d.getVar('UBOOT_PROVIDES_BOOT_CONTAINER') == '1', 'imx-boot-container', '')}
10
11DEPENDS += "bc-native dtc-native python3-setuptools-native lzop-native"
12
13# Location known to imx-boot component, where U-Boot artifacts
14# should be additionally deployed.
15# See below note above do_deploy:append:mx8m for the purpose of
16# this delopyment location
17BOOT_TOOLS = "imx-boot-tools"
18
19PROVIDES += "u-boot"
20
21B = "${WORKDIR}/build"
22
23# FIXME: Allow linking of 'tools' binaries with native libraries
24# used for generating the boot logo and other tools used
25# during the build process.
26EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CPPFLAGS}" \
27 HOSTLDFLAGS="${BUILD_LDFLAGS}" \
28 HOSTSTRIP=true'
29
30PACKAGE_ARCH = "${MACHINE_ARCH}"
31COMPATIBLE_MACHINE = "(mxs|mx5|mx6|mx7|vf|use-mainline-bsp)"