summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2024.01.bb
diff options
context:
space:
mode:
authorOleksandr Suvorov <oleksandr.suvorov@foundries.io>2024-02-17 17:16:48 +0200
committerOleksandr Suvorov <oleksandr.suvorov@foundries.io>2024-02-17 17:20:37 +0200
commitae992b9fb8b2acf9fa87ea326baf098e877c5ba1 (patch)
treec05c04daedca687e7cc36efdc3025205d9139a4a /recipes-bsp/u-boot/u-boot-fslc-mxsboot_2024.01.bb
parent71b63dd91dbc8d28921129052c2d7abaea174d2f (diff)
downloadmeta-freescale-ae992b9fb8b2acf9fa87ea326baf098e877c5ba1.tar.gz
u-boot-fslc: upgrade to v2024.01
U-Boot fork has been updated to include tagged version v2024.01 from upstream. Following commits were ported from 2023.10+fslc to this version: - 9ff224ca003 imx: iMX6: Define disconnect_from_pc function - a429b3dcdd5 MLK-21854-2 imx: uuu: Update autoboot to run uuu or fastboot - cbfd9b3fd03 pico-imx6ul, pico-imx7d: Explain how to use eMMC user partition - 58cb813aa7e mx6sabre_common: Dynamically change the video output - f1ac9d18650 mx6sabresd: Enable video interfaces in bootargs Signed-off-by: Oleksandr Suvorov <oleksandr.suvorov@foundries.io>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-fslc-mxsboot_2024.01.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mxsboot_2024.01.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2024.01.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2024.01.bb
new file mode 100644
index 00000000..b7e4ca76
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2024.01.bb
@@ -0,0 +1,42 @@
1require u-boot-fslc-common_${PV}.inc
2
3DESCRIPTION = "U-boot bootloader mxsboot tool"
4SECTION = "bootloader"
5
6inherit python3native
7
8DEPENDS += " \
9 bison-native \
10 dtc \
11 gnutls \
12 openssl \
13 python3-setuptools-native \
14 swig-native \
15 util-linux-libuuid \
16"
17
18PROVIDES = "u-boot-mxsboot"
19
20EXTRA_OEMAKE:class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y'
21EXTRA_OEMAKE:class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y'
22EXTRA_OEMAKE:class-nativesdk = 'CROSS_COMPILE="${HOST_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y'
23
24do_compile () {
25 oe_runmake -C ${S} O=${B} tools-only_defconfig
26
27 # Disable CONFIG_CMD_LICENSE, license.h is not used by tools and
28 # generating it requires bin2header tool, which for target build
29 # is built with target tools and thus cannot be executed on host.
30 sed -i "s/CONFIG_CMD_LICENSE=.*/# CONFIG_CMD_LICENSE is not set/" .config
31
32 oe_runmake -C ${S} O=${B} cross_tools NO_SDL=1
33}
34
35do_install () {
36 install -Dm 0755 tools/mxsboot ${D}${bindir}/uboot-mxsboot
37 ln -sf uboot-mxsboot ${D}${bindir}/mxsboot
38}
39
40COMPATIBLE_MACHINE:class-target = "(mxs-generic-bsp)"
41
42BBCLASSEXTEND = "native nativesdk"