summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2019.07.bb
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2019-06-14 15:14:54 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2019-06-21 18:16:27 -0300
commite53bafea3cad0366146ef2963ae2374b4b9095fb (patch)
tree892094325b6ca82af8a381011315f56a3932747f /recipes-bsp/u-boot/u-boot-fslc-mxsboot_2019.07.bb
parent0552378a5b1b32d70e09c550354d34b34a9595c5 (diff)
downloadmeta-freescale-e53bafea3cad0366146ef2963ae2374b4b9095fb.tar.gz
u-boot-fslc: Upgrade 2019.04 -> 2019.07
This upgrades to the next U-Boot release 2019-07. This is based on the 2019.07-rc4 and includes the last fixes being worked on for the i.MX family. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-fslc-mxsboot_2019.07.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mxsboot_2019.07.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2019.07.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2019.07.bb
new file mode 100644
index 00000000..9123b331
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2019.07.bb
@@ -0,0 +1,32 @@
1require u-boot-fslc-common_${PV}.inc
2
3DESCRIPTION = "U-boot bootloader mxsboot tool"
4SECTION = "bootloader"
5
6DEPENDS = "bison-native dtc openssl"
7
8PROVIDES = "u-boot-mxsboot"
9
10EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y'
11EXTRA_OEMAKE_class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y'
12EXTRA_OEMAKE_class-nativesdk = 'CROSS_COMPILE="${HOST_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y'
13
14do_compile () {
15 oe_runmake sandbox_defconfig
16
17 # Disable CONFIG_CMD_LICENSE, license.h is not used by tools and
18 # generating it requires bin2header tool, which for target build
19 # is built with target tools and thus cannot be executed on host.
20 sed -i "s/CONFIG_CMD_LICENSE=.*/# CONFIG_CMD_LICENSE is not set/" .config
21
22 oe_runmake cross_tools NO_SDL=1
23}
24
25do_install () {
26 install -Dm 0755 tools/mxsboot ${D}${bindir}/uboot-mxsboot
27 ln -sf uboot-mxsboot ${D}${bindir}/mxsboot
28}
29
30COMPATIBLE_MACHINE_class-target = "(mxs|mx5|mx6|mx7|vf|use-mainline-bsp)"
31
32BBCLASSEXTEND = "native nativesdk"