summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2015.04.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-15 17:14:27 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-16 15:01:29 -0300
commitf8517afc7a5ada4538b3b7d397fa32586d57ffe5 (patch)
tree79349f091306d1760fd4687e62336ffa8fb8c721 /recipes-bsp/u-boot/u-boot-fslc-mxsboot_2015.04.bb
parentc92b415d653afc55f33b6b93fb9248193bfd4fa0 (diff)
downloadmeta-freescale-f8517afc7a5ada4538b3b7d397fa32586d57ffe5.tar.gz
Move meta-fsl-arm content to layer root
The meta-fsl-arm is going to be used as the base for this layer. It contains a clean history and allowing a more granullar set of changes. This commit is just a rename of all contents of meta-fsl-arm subdirectory to this layer's root, subsequent changes are based on top of that. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-fslc-mxsboot_2015.04.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mxsboot_2015.04.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2015.04.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2015.04.bb
new file mode 100644
index 00000000..3981b604
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2015.04.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "U-boot bootloader mxsboot tool"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
4SECTION = "bootloader"
5DEPENDS = "openssl"
6PROVIDES = "u-boot-mxsboot"
7
8PV = "v2015.04+git${SRCPV}"
9
10SRCREV = "10aced37cecf117e54e71bd700228f57dc34e579"
11SRCBRANCH = "patches-2015.04"
12
13SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}"
14
15S = "${WORKDIR}/git"
16
17inherit fsl-u-boot-localversion
18
19EXTRA_OEMAKE = 'HOSTCC="${CC} ${CPPFLAGS}" HOSTLDFLAGS="-L${libdir} -L${base_libdir}" HOSTSTRIP=true CONFIG_MX28=y'
20
21do_configure () {
22 oe_runmake sandbox_defconfig
23}
24
25do_compile () {
26 oe_runmake tools-only
27}
28
29do_install () {
30 install -d ${D}${bindir}
31 install -m 0755 tools/mxsboot ${D}${bindir}/uboot-mxsboot
32 ln -sf uboot-mxsboot ${D}${bindir}/mxsboot
33}
34
35BBCLASSEXTEND = "native nativesdk"