summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/rcw
diff options
context:
space:
mode:
authorZongchun Yu <zongchun.yu@nxp.com>2016-07-16 00:28:38 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-07-22 11:30:51 -0300
commite347d641489a5c67c4ae014db3368ed77f254375 (patch)
treec61edecc80d49e26dca5253338742fa26bcf5e5b /recipes-bsp/rcw
parentac8d7fb81b1108507038151f9dfcf831546c26a1 (diff)
downloadmeta-freescale-e347d641489a5c67c4ae014db3368ed77f254375.tar.gz
ls2-rcw: Add recipe
Signed-off-by: Zongchun Yu <zongchun.yu@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/rcw')
-rw-r--r--recipes-bsp/rcw/ls2-rcw_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-bsp/rcw/ls2-rcw_git.bb b/recipes-bsp/rcw/ls2-rcw_git.bb
new file mode 100644
index 00000000..b6d9ccd3
--- /dev/null
+++ b/recipes-bsp/rcw/ls2-rcw_git.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Reset Configuration Word"
2DESCRIPTION = "Reset Configuration Word - hardware boot-time parameters for the QorIQ targets"
3LICENSE = "Freescale-EULA"
4LIC_FILES_CHKSUM = "file://EULA;md5=c9ae442cf1f9dd6c13dfad64b0ffe73f"
5
6inherit deploy
7
8INHIBIT_DEFAULT_DEPS = "1"
9PACKAGE_ARCH = "${MACHINE_ARCH}"
10
11SRC_URI = "git://git.freescale.com/ppc/sdk/ls2-rcw.git;branch=sdk-v2.0.x"
12SRCREV = "74ec3bcdf33fbbedf417b800e0d486d1e8031115"
13
14S = "${WORKDIR}/git"
15
16do_install () {
17 install -d ${D}/boot/rcw
18 cp -r ${S}/ls2080a/RDB/* ${D}/boot/rcw
19}
20
21do_deploy () {
22 install -d ${DEPLOYDIR}/rcw
23 cp -r ${S}/ls2080a/RDB/* ${DEPLOYDIR}/rcw
24}
25addtask deploy before do_build after do_install
26
27PACKAGES += "${PN}-image"
28FILES_${PN}-image += "/boot"
29COMPATIBLE_MACHINE = "(ls2080ardb)"