diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-15 17:14:27 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-16 15:01:29 -0300 |
commit | f8517afc7a5ada4538b3b7d397fa32586d57ffe5 (patch) | |
tree | 79349f091306d1760fd4687e62336ffa8fb8c721 /recipes-bsp/rcw | |
parent | c92b415d653afc55f33b6b93fb9248193bfd4fa0 (diff) | |
download | meta-freescale-f8517afc7a5ada4538b3b7d397fa32586d57ffe5.tar.gz |
Move meta-fsl-arm content to layer root
The meta-fsl-arm is going to be used as the base for this layer. It
contains a clean history and allowing a more granullar set of changes.
This commit is just a rename of all contents of meta-fsl-arm
subdirectory to this layer's root, subsequent changes are based on top
of that.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/rcw')
-rw-r--r-- | recipes-bsp/rcw/rcw/rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch | 57 | ||||
-rw-r--r-- | recipes-bsp/rcw/rcw_git.bb | 36 |
2 files changed, 93 insertions, 0 deletions
diff --git a/recipes-bsp/rcw/rcw/rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch b/recipes-bsp/rcw/rcw/rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch new file mode 100644 index 00000000..49d99fc5 --- /dev/null +++ b/recipes-bsp/rcw/rcw/rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch | |||
@@ -0,0 +1,57 @@ | |||
1 | From f2e796c903b2a3f81dbd38da3dc087cb7539d307 Mon Sep 17 00:00:00 2001 | ||
2 | From: Zhenhua Luo <zhenhua.luo@freescale.com> | ||
3 | Date: Wed, 3 Sep 2014 03:03:42 -0500 | ||
4 | Subject: [PATCH] Makefile: make BOARDS/DESTDIR overidable and add endian | ||
5 | switch | ||
6 | |||
7 | 1. For one specific board, no need to build the rcw for all supported | ||
8 | targets, make BOARDS and DESTDIR overridable to achieve this. | ||
9 | 2. Add the endian swap for qspiboot rcw | ||
10 | |||
11 | Upstream-Status: Pending | ||
12 | |||
13 | Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com> | ||
14 | --- | ||
15 | Makefile | 4 ++-- | ||
16 | Makefile.inc | 9 +++++++-- | ||
17 | 2 files changed, 9 insertions(+), 4 deletions(-) | ||
18 | |||
19 | diff --git a/Makefile b/Makefile | ||
20 | index 6ec1697..0f94293 100644 | ||
21 | --- a/Makefile | ||
22 | +++ b/Makefile | ||
23 | @@ -1,5 +1,5 @@ | ||
24 | -DESTDIR = . | ||
25 | -BOARDS = b4420qds b4860qds \ | ||
26 | +DESTDIR ?= . | ||
27 | +BOARDS ?= b4420qds b4860qds \ | ||
28 | ls1021aqds ls1021atwr \ | ||
29 | p2041rdb p3041ds p4080ds p5020ds p5040ds \ | ||
30 | t1024qds t1023rdb t1024rdb t1040rdb t1042rdb t1042rdb_pi t1040qds \ | ||
31 | diff --git a/Makefile.inc b/Makefile.inc | ||
32 | index 4cadb2e..6e8b78f 100644 | ||
33 | --- a/Makefile.inc | ||
34 | +++ b/Makefile.inc | ||
35 | @@ -1,4 +1,4 @@ | ||
36 | -DESTDIR = . | ||
37 | +DESTDIR ?= . | ||
38 | INSTALL = install | ||
39 | PYTHON ?= python2 | ||
40 | RCW = $(PYTHON) ../rcw.py | ||
41 | @@ -18,7 +18,12 @@ all: $(targets) | ||
42 | install: $(targets) | ||
43 | $(INSTALL) -d $(DESTDIR) | ||
44 | @for file in $^; do \ | ||
45 | - $(INSTALL) -m 644 -D $$file $(DESTDIR)/$$file; \ | ||
46 | + case $$file in \ | ||
47 | + *qspiboot*) file_swap="`echo $$file | sed -e 's/qspiboot/qspiboot_swap/'`"; \ | ||
48 | + tclsh byte_swap.tcl $$file $$file_swap 8 ; \ | ||
49 | + $(INSTALL) -m 644 -D $$file_swap $(DESTDIR)/$$file_swap ;; \ | ||
50 | + *) $(INSTALL) -m 644 -D $$file $(DESTDIR)/$$file; \ | ||
51 | + esac \ | ||
52 | done | ||
53 | $(INSTALL) -m 644 -D README $(DESTDIR) | ||
54 | |||
55 | -- | ||
56 | 1.7.9.7 | ||
57 | |||
diff --git a/recipes-bsp/rcw/rcw_git.bb b/recipes-bsp/rcw/rcw_git.bb new file mode 100644 index 00000000..2a03309c --- /dev/null +++ b/recipes-bsp/rcw/rcw_git.bb | |||
@@ -0,0 +1,36 @@ | |||
1 | SUMMARY = "Reset Configuration Word" | ||
2 | DESCRIPTION = "Reset Configuration Word - hardware boot-time parameters for the QorIQ targets" | ||
3 | LICENSE = "BSD" | ||
4 | LIC_FILES_CHKSUM = "file://rcw.py;beginline=8;endline=28;md5=9ba0b28922dd187b06b6c8ebcfdd208e" | ||
5 | |||
6 | DEPENDS += "change-file-endianess-native" | ||
7 | |||
8 | inherit deploy | ||
9 | |||
10 | SRCBRANCH = "master" | ||
11 | SRCREV = "426f7a6535d93dac76f5125035e0938a85e778d2" | ||
12 | SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;branch=${SRCBRANCH} \ | ||
13 | file://rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch \ | ||
14 | " | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | EXTRA_OEMAKE = "BOARDS=${@d.getVar('MACHINE', True).replace('-64b','')} DESTDIR=${D}/boot/rcw/" | ||
19 | |||
20 | do_install () { | ||
21 | oe_runmake install | ||
22 | } | ||
23 | |||
24 | do_deploy () { | ||
25 | install -d ${DEPLOYDIR}/rcw | ||
26 | cp -r ${D}/boot/rcw/* ${DEPLOYDIR}/rcw/ | ||
27 | } | ||
28 | addtask deploy after do_install | ||
29 | |||
30 | PACKAGES += "${PN}-image" | ||
31 | FILES_${PN}-image += "/boot" | ||
32 | |||
33 | ALLOW_EMPTY_${PN} = "1" | ||
34 | |||
35 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
36 | COMPATIBLE_MACHINE = "(ls102xa)" | ||