summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/rcw/rcw_git.bb
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2017-10-18 13:06:33 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2017-10-18 11:42:30 -0200
commitdb430946b384e31aa33cf35f9fdb96ed8520e102 (patch)
treefd71754d2a8558524326b4e286e46cfb66e5b698 /recipes-bsp/rcw/rcw_git.bb
parent96b179c69979fe3222509ec021f7aabc6992815a (diff)
downloadmeta-freescale-db430946b384e31aa33cf35f9fdb96ed8520e102.tar.gz
rcw :update recipe
*update to 1a6236a *This includes the following changes: 1a6236a - LS1012ARDB: Change rcw for secure boot cdf4b72 - rcw: ls1088aqds: Add SCSI errata for detecttion of sata 16072f7 - armv8:LS1012A: RCW supporting 1GHz CPU frequency 90aef03 - LS1088ARDB:Reduce size in block copy command 53518dc - rcw: ls1088ardb: Add SCSI errata for detecttion of sata 0a869b3 - ls1021a: add workaround for pcie erratum A-007997 and A-007815 e7f18e5 - ls2088ardb: Add RCW for with platform frequency 700MHz 6f324fc - Use BSD license for both rcw and binary files c69799f - Added copyright to byte_swap.tcl bfe8c5e - Renaming COPYING as BSD-LICENSE *update LIC_FILES_CHKSUM to point to LICENSE Renaming BSD-LICENSE * add support for Qoriq. * strip possible '-32b', '-64b' and '-be' to match folder name. Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/rcw/rcw_git.bb')
-rw-r--r--recipes-bsp/rcw/rcw_git.bb16
1 files changed, 11 insertions, 5 deletions
diff --git a/recipes-bsp/rcw/rcw_git.bb b/recipes-bsp/rcw/rcw_git.bb
index 877822f2..9c2b156a 100644
--- a/recipes-bsp/rcw/rcw_git.bb
+++ b/recipes-bsp/rcw/rcw_git.bb
@@ -1,23 +1,29 @@
1SUMMARY = "Reset Configuration Word" 1SUMMARY = "Reset Configuration Word"
2DESCRIPTION = "Reset Configuration Word - hardware boot-time parameters for the QorIQ targets" 2DESCRIPTION = "Reset Configuration Word - hardware boot-time parameters for the QorIQ targets"
3LICENSE = "BSD" 3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://BSD-LICENSE;md5=627727dce58484c4bd5f9b19665d81b3" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=be7e0b2ce5a7a1f4f25a6d82cec1f47d"
5 5
6DEPENDS += "change-file-endianess-native tcl-native" 6DEPENDS += "change-file-endianess-native tcl-native"
7 7
8inherit deploy 8inherit deploy siteinfo
9 9
10SRC_URI = "git://github.com/qoriq-open-source/rcw.git;nobranch=1" 10SRC_URI = "git://github.com/qoriq-open-source/rcw.git;nobranch=1"
11SRCREV = "bfe8c5eb72cbae387af1c8662957caa801c2309f" 11SRCREV = "1a6236a34166219de324a105971eb9de05cde76e"
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14 14
15export PYTHON = "${USRBINPATH}/python2" 15export PYTHON = "${USRBINPATH}/python2"
16 16
17EXTRA_OEMAKE = "BOARDS=${@d.getVar('MACHINE', True).replace('-64b','').replace('-32b','')} DESTDIR=${D}/boot/rcw/" 17M="${@d.getVar('MACHINE', True).replace('-64b','').replace('-32b','').replace('-${SITEINFO_ENDIANNESS}','')}"
18 18
19do_install () { 19do_install () {
20 oe_runmake install 20 if [ -f ${S}/${M}/Makefile ]; then
21 oe_runmake BOARDS=${M} DESTDIR=${D}/boot/rcw/ install
22 else
23 install -d ${D}/boot/rcw
24 cp -a ${S}/${M} ${D}/boot/rcw/
25 chown -R root:root ${D}
26 fi
21 for f in `find ${D}/boot/rcw/ -name "*qspiboot*"`;do 27 for f in `find ${D}/boot/rcw/ -name "*qspiboot*"`;do
22 if echo $f |grep -q "qspiboot_sben"; then 28 if echo $f |grep -q "qspiboot_sben"; then
23 continue 29 continue