summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/rcw/rcw_git.bb
diff options
context:
space:
mode:
authorChunrong Guo <B40290@freescale.com>2016-03-22 11:04:30 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-08-12 11:41:02 -0300
commit6b396ec236c23462601f96f5db45de86052f38dd (patch)
tree5c5ad3d75b5c223dfa17889467470da7703792e9 /recipes-bsp/rcw/rcw_git.bb
parent339f7606dd521099c02ac24c04e3e1cdb0f47c08 (diff)
downloadmeta-freescale-6b396ec236c23462601f96f5db45de86052f38dd.tar.gz
rcw: update to 1af724b
* change license to Freescale-EULA * add tcl-native to DEPENDS as byte_swap.tcl is needed to run * run byte_swap.tcl for all the boards * update COMPATIBLE_MACHINE to support ls1043a, and exclude ls2080a Changelog: 1af724b update End-User License Agreement 76854c9 ls1043aqds: revise the description of SERDES1 Protocol 0x3358 970cc5d ls1043aqds: add SATA support under QSPI boot 017ed94 ls1021a/ls1043a: byte_swap: should 8 byte alignment ea90914 ls1021a: remove the unnecessary PBI 3f37603 ls1043aqds: Clear SerDes RxBoost on lane D cbf49c1 LS1043a-RDB: Add RCW files for UEFI bootloader 419bd59 ls1043ardb: SECURE_BOOT- RCW added ae3461a qe-tdm: add qe-tdm support on ls1043ardb 26042fa ls1043ardb: Add RCW for ls1043ardb board 4ae7fc3 ls1043aqds: Add RCW for ls1043aqds board Signed-off-by: Ting Liu <ting.liu@nxp.com>
Diffstat (limited to 'recipes-bsp/rcw/rcw_git.bb')
-rw-r--r--recipes-bsp/rcw/rcw_git.bb18
1 files changed, 8 insertions, 10 deletions
diff --git a/recipes-bsp/rcw/rcw_git.bb b/recipes-bsp/rcw/rcw_git.bb
index 9be53f24..64255b86 100644
--- a/recipes-bsp/rcw/rcw_git.bb
+++ b/recipes-bsp/rcw/rcw_git.bb
@@ -1,14 +1,16 @@
1SUMMARY = "Reset Configuration Word" 1SUMMARY = "Reset Configuration Word"
2DESCRIPTION = "Reset Configuration Word - hardware boot-time parameters for the QorIQ targets" 2DESCRIPTION = "Reset Configuration Word - hardware boot-time parameters for the QorIQ targets"
3LICENSE = "BSD" 3LICENSE = "Freescale-EULA"
4LIC_FILES_CHKSUM = "file://rcw.py;beginline=8;endline=28;md5=9ba0b28922dd187b06b6c8ebcfdd208e" 4LIC_FILES_CHKSUM = "file://EULA;md5=c9ae442cf1f9dd6c13dfad64b0ffe73f"
5 5
6DEPENDS += "change-file-endianess-native" 6DEPENDS += "change-file-endianess-native tcl-native"
7 7
8inherit deploy 8inherit deploy
9 9
10SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;branch=sdk-v1.9.x" 10PACKAGE_ARCH = "${MACHINE_ARCH}"
11SRCREV = "521008fe6ec9897fe245e1c1241fc27dad98f24d" 11
12SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;branch=sdk-v2.0.x"
13SRCREV = "1af724b64347170e9d9ba8e8f277dd30026a1a7e"
12 14
13S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
14 16
@@ -16,8 +18,6 @@ EXTRA_OEMAKE = "BOARDS=${@d.getVar('MACHINE', True).replace('-64b','')} DESTDIR=
16 18
17do_install () { 19do_install () {
18 oe_runmake install 20 oe_runmake install
19}
20do_install_append_ls102xa () {
21 for f in `find ${D}/boot/rcw/ -name "*qspiboot*"`;do 21 for f in `find ${D}/boot/rcw/ -name "*qspiboot*"`;do
22 f_swap=`echo $f |sed -e 's/qspiboot/qspiboot_swap/'` 22 f_swap=`echo $f |sed -e 's/qspiboot/qspiboot_swap/'`
23 tclsh ${STAGING_BINDIR_NATIVE}/byte_swap.tcl $f $f_swap 8 23 tclsh ${STAGING_BINDIR_NATIVE}/byte_swap.tcl $f $f_swap 8
@@ -32,6 +32,4 @@ addtask deploy after do_install
32 32
33PACKAGES += "${PN}-image" 33PACKAGES += "${PN}-image"
34FILES_${PN}-image += "/boot" 34FILES_${PN}-image += "/boot"
35 35COMPATIBLE_MACHINE = "(qoriq-ppc|ls1021a|ls1043a)"
36PACKAGE_ARCH = "${MACHINE_ARCH}"
37COMPATIBLE_MACHINE = "(qoriq)"