summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/rcw/rcw_git.bb
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@nxp.com>2016-12-20 20:18:58 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2017-01-11 10:53:43 -0200
commit420f9a4f546c05426470be0bc169183dc7f1c747 (patch)
tree6f17881c69b9fee837e7ff310bb605d3733569c8 /recipes-bsp/rcw/rcw_git.bb
parent8eccdeb615fa7f5c186e942e196bfbf87d9c24dd (diff)
downloadmeta-freescale-420f9a4f546c05426470be0bc169183dc7f1c747.tar.gz
rcw: upgrade to SDK 2.0 GA-1611 release
* disable the endianness switch for qspi u-boot of SEC boot * included the following commits. * 3252b8c Merge pull request #20 in SDK/rcw from ~B21989/sdk-rcw:jira/QSDK-3097 to master * cd271ee Merge pull request #19 in SDK/rcw from ~B52263/rcw:jira/QSDK-3096 to master * 6a558a2 ls1021a: Fix QSPI endian issue for QSPI boot on LS1021A boards * fbfddb3 ls1043a: Fix QSPI endian issue for QSPI boot on LS1043AQDS * 2485a22 ls1046a: fix PBI of changing QSPI endianness * 7304127 ls1043ardb: adds a RCW with GIC 4K supported * d413878 ls1043a: Add PBI of changing GIC offset to 4K * e914a5f Add a tclsh script to swap the rcw endian. * 8411b78 ls1046aqds: Add RCW for ls1046aqds board * 6d486d4 ls1046ardb: Add RCW for ls1046ardb board * 14de148 arm: ls1021a: add the core frequency to 1.2GHZ support * 98b6bc3 t2080rdb: update SRDS2PLL2CR1 to 0x08004100 for errata A-007186 Signed-off-by: Ting Liu <ting.liu@nxp.com> Signed-off-by: Zhenhua Luo <zhenhua.luo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/rcw/rcw_git.bb')
-rw-r--r--recipes-bsp/rcw/rcw_git.bb13
1 files changed, 8 insertions, 5 deletions
diff --git a/recipes-bsp/rcw/rcw_git.bb b/recipes-bsp/rcw/rcw_git.bb
index 81178617..e00c0a6e 100644
--- a/recipes-bsp/rcw/rcw_git.bb
+++ b/recipes-bsp/rcw/rcw_git.bb
@@ -8,17 +8,21 @@ DEPENDS += "change-file-endianess-native tcl-native"
8inherit deploy 8inherit deploy
9 9
10SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;branch=sdk-v2.0.x" 10SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;branch=sdk-v2.0.x"
11SRCREV = "6ae9086528019ab55968da05c25bd319737c8e62" 11SRCREV = "3252b8cce8e5a214c8e652121ef9b9460663c65a"
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14 14
15EXTRA_OEMAKE = "BOARDS=${@d.getVar('MACHINE', True).replace('-64b','')} DESTDIR=${D}/boot/rcw/" 15EXTRA_OEMAKE = "BOARDS=${@d.getVar('MACHINE', True).replace('-64b','').replace('-32b','')} DESTDIR=${D}/boot/rcw/"
16 16
17do_install () { 17do_install () {
18 oe_runmake install 18 oe_runmake install
19 for f in `find ${D}/boot/rcw/ -name "*qspiboot*"`;do 19 for f in `find ${D}/boot/rcw/ -name "*qspiboot*"`;do
20 if echo $f |grep -q "qspiboot_sben"; then
21 continue
22 fi
20 f_swap=`echo $f |sed -e 's/qspiboot/qspiboot_swap/'` 23 f_swap=`echo $f |sed -e 's/qspiboot/qspiboot_swap/'`
21 tclsh ${STAGING_BINDIR_NATIVE}/byte_swap.tcl $f $f_swap 8 24 tclsh ${STAGING_BINDIR_NATIVE}/byte_swap.tcl $f $f_swap 8
25 mv -f $f_swap $f
22 done 26 done
23} 27}
24 28
@@ -31,6 +35,5 @@ addtask deploy after do_install
31PACKAGES += "${PN}-image" 35PACKAGES += "${PN}-image"
32FILES_${PN}-image += "/boot" 36FILES_${PN}-image += "/boot"
33 37
34COMPATIBLE_MACHINE = "(qoriq-ppc|ls1021a|ls1043a)" 38COMPATIBLE_MACHINE = "(qoriq)"
35PACKAGE_ARCH = "${MACHINE_SOCARCH}" 39PACKAGE_ARCH = "${MACHINE_ARCH}"
36