summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/rcw/rcw_git.bb
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2016-01-09 14:43:22 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-04-19 15:03:23 -0300
commit238deb34afc3326989d5efe104bdc8449ffa0968 (patch)
tree7208b1859442ba25e89569107f3f37bf17806caf /recipes-bsp/rcw/rcw_git.bb
parent8b19b82e5422fbc924bc6e80034e9b1f665ce0fe (diff)
downloadmeta-freescale-238deb34afc3326989d5efe104bdc8449ffa0968.tar.gz
rcw: swap qspi binary in do_install_append
Signed-off-by: Ting Liu <ting.liu@nxp.com> Signed-off-by: Zhenhua Luo <zhenhua.luo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/rcw/rcw_git.bb')
-rw-r--r--recipes-bsp/rcw/rcw_git.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/recipes-bsp/rcw/rcw_git.bb b/recipes-bsp/rcw/rcw_git.bb
index 016ef820..0647c2ce 100644
--- a/recipes-bsp/rcw/rcw_git.bb
+++ b/recipes-bsp/rcw/rcw_git.bb
@@ -9,9 +9,7 @@ inherit deploy
9 9
10SRCBRANCH = "master" 10SRCBRANCH = "master"
11SRCREV = "426f7a6535d93dac76f5125035e0938a85e778d2" 11SRCREV = "426f7a6535d93dac76f5125035e0938a85e778d2"
12SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;branch=${SRCBRANCH} \ 12SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;branch=${SRCBRANCH}"
13 file://rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch \
14"
15 13
16S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
17 15
@@ -20,6 +18,12 @@ EXTRA_OEMAKE = "BOARDS=${@d.getVar('MACHINE', True).replace('-64b','')} DESTDIR=
20do_install () { 18do_install () {
21 oe_runmake install 19 oe_runmake install
22} 20}
21do_install_append_ls102xa () {
22 for f in `find ${D}/boot/rcw/ -name "*qspiboot*"`;do
23 f_swap=`echo $f |sed -e 's/qspiboot/qspiboot_swap/'`
24 tclsh ${STAGING_BINDIR_NATIVE}/byte_swap.tcl $f $f_swap 8
25 done
26}
23 27
24do_deploy () { 28do_deploy () {
25 install -d ${DEPLOYDIR}/rcw 29 install -d ${DEPLOYDIR}/rcw