summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/rcw/rcw_git.bb
diff options
context:
space:
mode:
authorJens Rehsack <jens.rehsack.ext@safrangroup.com>2019-12-13 18:04:33 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2019-12-16 18:53:56 -0300
commit3b00d121b420192384e3c8f3c03f1287be0193c6 (patch)
tree95ec0fbcd6ace581f3262f5c92188b065af5b68c /recipes-bsp/rcw/rcw_git.bb
parent4b72db3f521cd9c9bea5b2e93aebf01d9732e7b4 (diff)
downloadmeta-freescale-3b00d121b420192384e3c8f3c03f1287be0193c6.tar.gz
rcw: easy overriding machine in derived layers
Modify rcw recipe to allow define machine dependent targets in derived layers for dedicated PCBs based on QorIQ socs. Signed-off-by: Jens Rehsack <sno@netbsd.org>
Diffstat (limited to 'recipes-bsp/rcw/rcw_git.bb')
-rw-r--r--recipes-bsp/rcw/rcw_git.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/recipes-bsp/rcw/rcw_git.bb b/recipes-bsp/rcw/rcw_git.bb
index fed9f864..63d8a195 100644
--- a/recipes-bsp/rcw/rcw_git.bb
+++ b/recipes-bsp/rcw/rcw_git.bb
@@ -16,15 +16,15 @@ export PYTHON = "${USRBINPATH}/python3"
16 16
17M="${@d.getVar('MACHINE').replace('-64b','').replace('-32b','').replace('-${SITEINFO_ENDIANNESS}','')}" 17M="${@d.getVar('MACHINE').replace('-64b','').replace('-32b','').replace('-${SITEINFO_ENDIANNESS}','')}"
18 18
19BOARD_TARGETS="${M}"
20BOARD_TARGETS_ls2088ardb="${M} ${M}_rev1.1"
21BOARD_TARGETS_ls1088ardb-pb="ls1088ardb"
22
19do_install () { 23do_install () {
20 if [ ${M} = ls2088ardb ]; then 24 for BT in ${BOARD_TARGETS}
21 oe_runmake BOARDS=${M} DESTDIR=${D}/boot/rcw/ install 25 do
22 oe_runmake BOARDS=${M}_rev1.1 DESTDIR=${D}/boot/rcw/ install 26 oe_runmake BOARDS=${BT} DESTDIR=${D}/boot/rcw/ install
23 elif [ ${M} = ls1088ardb-pb ]; then 27 done
24 oe_runmake BOARDS=ls1088ardb DESTDIR=${D}/boot/rcw/ install
25 else
26 oe_runmake BOARDS=${M} DESTDIR=${D}/boot/rcw/ install
27 fi
28} 28}
29 29
30do_deploy () { 30do_deploy () {