diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-15 17:14:27 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-16 15:01:29 -0300 |
commit | f8517afc7a5ada4538b3b7d397fa32586d57ffe5 (patch) | |
tree | 79349f091306d1760fd4687e62336ffa8fb8c721 /recipes-bsp/qe-ucode | |
parent | c92b415d653afc55f33b6b93fb9248193bfd4fa0 (diff) | |
download | meta-freescale-f8517afc7a5ada4538b3b7d397fa32586d57ffe5.tar.gz |
Move meta-fsl-arm content to layer root
The meta-fsl-arm is going to be used as the base for this layer. It
contains a clean history and allowing a more granullar set of changes.
This commit is just a rename of all contents of meta-fsl-arm
subdirectory to this layer's root, subsequent changes are based on top
of that.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/qe-ucode')
-rw-r--r-- | recipes-bsp/qe-ucode/qe-ucode_git.bb | 36 |
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-bsp/qe-ucode/qe-ucode_git.bb b/recipes-bsp/qe-ucode/qe-ucode_git.bb new file mode 100644 index 00000000..28af4b65 --- /dev/null +++ b/recipes-bsp/qe-ucode/qe-ucode_git.bb | |||
@@ -0,0 +1,36 @@ | |||
1 | DESCRIPTION = "qe microcode binary" | ||
2 | SECTION = "qe-ucode" | ||
3 | LICENSE = "Freescale-EULA" | ||
4 | LIC_FILES_CHKSUM = "file://EULA;md5=60037ccba533a5995e8d1a838d85799c" | ||
5 | |||
6 | inherit deploy | ||
7 | |||
8 | SRC_URI = "git://git.freescale.com/ppc/sdk/qe-ucode.git;nobranch=1" | ||
9 | SRCREV= "49efc94b553de5c2a9bd28093592eff0068e161c" | ||
10 | |||
11 | S = "${WORKDIR}/git" | ||
12 | |||
13 | python () { | ||
14 | if not d.getVar("QE_UCODE", True): | ||
15 | PN = d.getVar("PN", True) | ||
16 | FILE = os.path.basename(d.getVar("FILE", True)) | ||
17 | bb.debug(1, "To build %s, see %s for instructions on \ | ||
18 | setting up your qe-ucode" % (PN, FILE)) | ||
19 | raise bb.parse.SkipPackage("because QE_UCODE is not set") | ||
20 | } | ||
21 | |||
22 | do_install () { | ||
23 | install -d ${D}/boot | ||
24 | install -m 644 ${QE_UCODE} ${D}/boot | ||
25 | } | ||
26 | |||
27 | do_deploy () { | ||
28 | install -d ${DEPLOYDIR}/boot | ||
29 | install -m 644 ${QE_UCODE} ${DEPLOYDIR}/boot | ||
30 | } | ||
31 | addtask deploy before do_build after do_install | ||
32 | |||
33 | PACKAGES += "${PN}-image" | ||
34 | FILES_${PN}-image += "/boot/*" | ||
35 | ALLOW_EMPTY_${PN} = "1" | ||
36 | COMPATIBLE_MACHINE = "(ls102xa)" | ||