summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/ppfe-firmware
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2017-11-09 12:11:15 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2017-11-10 13:57:12 -0200
commit6ed3918ed0ba49f07cd7f14fc3e26bf9710a223c (patch)
tree748b142836d55f2ac6a5449de1578bade5eb97e5 /recipes-bsp/ppfe-firmware
parent709a722ae1479494b1e551c720e5b9a93cd487ff (diff)
downloadmeta-freescale-6ed3918ed0ba49f07cd7f14fc3e26bf9710a223c.tar.gz
ppfe-firmware: update recipes
*Deploy the binary in ls1012a/u-boot/ folder as it is standalone The ppfe-firmware is a standalone tool, deploy the binary like other images like u-boot/kernel/rcw. *fix missing binary in ls1012a/u-boot/ folder Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/ppfe-firmware')
-rw-r--r--recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb b/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb
index ab0015a1..9c93d333 100644
--- a/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb
+++ b/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb
@@ -4,6 +4,8 @@ LIC_FILES_CHKSUM = "file://Freescale-Binary-EULA;md5=f1c407c0fccab5cd0bf9b92565f
4 4
5INHIBIT_DEFAULT_DEPS = "1" 5INHIBIT_DEFAULT_DEPS = "1"
6 6
7inherit deploy
8
7SRC_URI = "git://github.com/qoriq-open-source/engine-pfe-bin.git;nobranch=1" 9SRC_URI = "git://github.com/qoriq-open-source/engine-pfe-bin.git;nobranch=1"
8SRCREV = "97cd13d3070d7199e62881bc495b332194b67edd" 10SRCREV = "97cd13d3070d7199e62881bc495b332194b67edd"
9 11
@@ -11,11 +13,20 @@ S = "${WORKDIR}/git"
11 13
12do_install () { 14do_install () {
13 install -d ${D}/lib/firmware 15 install -d ${D}/lib/firmware
16 install -d ${D}/boot/engine-pfe-bin
14 install -m 644 ${S}/Freescale-Binary-EULA ${D}/lib/firmware 17 install -m 644 ${S}/Freescale-Binary-EULA ${D}/lib/firmware
15 install -m 755 ${S}/ls1012a/slow_path/*.elf ${D}/lib/firmware 18 install -m 755 ${S}/ls1012a/slow_path/*.elf ${D}/lib/firmware
19 install -m 755 ${S}/ls1012a/u-boot/* ${D}/boot/engine-pfe-bin
20}
21
22do_deploy () {
23 install -d ${DEPLOYDIR}/engine-pfe-bin
24 cp -r ${D}/boot/engine-pfe-bin/* ${DEPLOYDIR}/engine-pfe-bin
16} 25}
17 26
18FILES_${PN} += "/lib/firmware" 27addtask deploy after do_install
28
29FILES_${PN} += "/lib/firmware /boot/"
19INSANE_SKIP_${PN} += "arch already-stripped" 30INSANE_SKIP_${PN} += "arch already-stripped"
20INHIBIT_PACKAGE_STRIP = "1" 31INHIBIT_PACKAGE_STRIP = "1"
21INHIBIT_SYSROOT_STRIP = "1" 32INHIBIT_SYSROOT_STRIP = "1"