summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/mxsldr/mxsldr
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-09-28 13:18:50 -0700
committerOtavio Salvador <otavio@ossystems.com.br>2018-09-28 17:29:11 -0300
commit9ae826a5ddb318e7f9248cbab426a509c69f1e19 (patch)
tree6be115b565a1d7604e2caadd11175fd290a75232 /recipes-bsp/mxsldr/mxsldr
parent16c528880f20c68731e645775d31c7445c95a8db (diff)
downloadmeta-freescale-9ae826a5ddb318e7f9248cbab426a509c69f1e19.tar.gz
mxldr: Fix QA errors seen on x86 builds
* Respect OE flags inside makefiles * Its not a autotooled recipe but a simple makefile based one Fixes NOTE: i586-yoe-linux-musl-objdump -p TOPDIR/build/tmp/work/i586-yoe-linux-musl/mxsldr/0.0.0+gitAUTOINC+c40d804725-r0/packages-split/mxsldr/usr/bin/mxsldr ERROR: QA Issue: No GNU_HASH in the elf binary: 'TOPDIR/build/tmp/work/i586-yoe-linux-musl/mxsldr/0.0.0+gitAUTOINC+c40d804725-r0/packages-split/mxsldr/usr/bin/mxsldr' [ldflags] Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/mxsldr/mxsldr')
-rw-r--r--recipes-bsp/mxsldr/mxsldr/0001-Do-not-ignore-OE-cflags-and-ldflags.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-bsp/mxsldr/mxsldr/0001-Do-not-ignore-OE-cflags-and-ldflags.patch b/recipes-bsp/mxsldr/mxsldr/0001-Do-not-ignore-OE-cflags-and-ldflags.patch
new file mode 100644
index 00000000..c8c8413a
--- /dev/null
+++ b/recipes-bsp/mxsldr/mxsldr/0001-Do-not-ignore-OE-cflags-and-ldflags.patch
@@ -0,0 +1,28 @@
1From 2f2e1ca77b4459475e5d649bd22e6bc8c3873695 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 25 Sep 2018 01:23:02 -0700
4Subject: [PATCH] Do not ignore OE cflags and ldflags
5
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7---
8 Makefile | 4 ++--
9 1 file changed, 2 insertions(+), 2 deletions(-)
10
11diff --git a/Makefile b/Makefile
12index afb4e32..d2763ed 100644
13--- a/Makefile
14+++ b/Makefile
15@@ -3,8 +3,8 @@ prefix ?= "/usr/local"
16
17 all: mxsldr
18
19-CFLAGS = `pkg-config --cflags libusb-1.0`
20-LDFLAGS = `pkg-config --libs libusb-1.0`
21+CFLAGS += `pkg-config --cflags libusb-1.0`
22+LDFLAGS += `pkg-config --libs libusb-1.0`
23
24 mxsldr: mxsldr.c
25 $(CC) $(CFLAGS) $(LDFLAGS) $^ -o $@ -lusb-1.0
26--
272.19.0
28