diff options
author | Jens Rehsack <sno@NetBSD.org> | 2020-02-10 15:37:56 +0100 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-02-11 18:25:22 -0300 |
commit | 24d974cc97eb15485c6a6ff3155ab11ae5b03f79 (patch) | |
tree | 44abe379f2dd63fe1bfbc8d618375f6bf67c7411 /recipes-bsp/mc-utils | |
parent | d6d57051cc5bfca6f7ec0232745f6d18f681134f (diff) | |
download | meta-freescale-24d974cc97eb15485c6a6ff3155ab11ae5b03f79.tar.gz |
mc-utils: split compile & install, fix RDB only
Instead of compiling dtc/dtl files during install stage, compile in
compile stage. Since some boards have RDB and QDS, allow build for
QDS (or manual created configuration) either.
Due broken patch (mixed spaces & tabs) affected lines are repared.
Signed-off-by: Jens Rehsack <sno@NetBSD.org>
Diffstat (limited to 'recipes-bsp/mc-utils')
-rw-r--r-- | recipes-bsp/mc-utils/mc-utils_git.bb | 26 |
1 files changed, 15 insertions, 11 deletions
diff --git a/recipes-bsp/mc-utils/mc-utils_git.bb b/recipes-bsp/mc-utils/mc-utils_git.bb index 39c26b57..d0b40bd0 100644 --- a/recipes-bsp/mc-utils/mc-utils_git.bb +++ b/recipes-bsp/mc-utils/mc-utils_git.bb | |||
@@ -19,24 +19,28 @@ MC_CFG_ls1088a = "ls1088a" | |||
19 | MC_CFG_ls2088a = "ls2088a" | 19 | MC_CFG_ls2088a = "ls2088a" |
20 | MC_CFG_lx2160a = "lx2160a" | 20 | MC_CFG_lx2160a = "lx2160a" |
21 | 21 | ||
22 | do_install () { | 22 | MC_FLAVOUR ?= "RDB" |
23 | |||
24 | do_compile () { | ||
23 | oe_runmake -C config | 25 | oe_runmake -C config |
26 | } | ||
24 | 27 | ||
28 | do_install () { | ||
25 | install -d ${D}/boot/mc-utils | 29 | install -d ${D}/boot/mc-utils |
26 | cp -r ${S}/config/${MC_CFG}/RDB/*.dtb ${D}/boot/mc-utils | 30 | cp -r ${S}/config/${MC_CFG}/${MC_FLAVOUR}/*.dtb ${D}/boot/mc-utils |
27 | if [ -d ${S}/config/${MC_CFG}/RDB/custom/ ]; then | 31 | if [ -d ${S}/config/${MC_CFG}/${MC_FLAVOUR}/custom/ ]; then |
28 | install -d ${D}/boot/mc-utils/custom | 32 | install -d ${D}/boot/mc-utils/custom |
29 | cp -r ${S}/config/${MC_CFG}/RDB/custom/*.dtb ${D}/boot/mc-utils/custom | 33 | cp -r ${S}/config/${MC_CFG}/${MC_FLAVOUR}/custom/*.dtb ${D}/boot/mc-utils/custom |
30 | fi | 34 | fi |
31 | } | 35 | } |
32 | 36 | ||
33 | do_deploy () { | 37 | do_deploy () { |
34 | install -d ${DEPLOYDIR}/mc-utils | 38 | install -d ${DEPLOYDIR}/mc-utils |
35 | cp -r ${S}/config/${MC_CFG}/RDB/*.dtb ${DEPLOYDIR}/mc-utils | 39 | cp -r ${S}/config/${MC_CFG}/${MC_FLAVOUR}/*.dtb ${DEPLOYDIR}/mc-utils |
36 | if [ -d ${S}/config/${MC_CFG}/RDB/custom/ ]; then | 40 | if [ -d ${S}/config/${MC_CFG}/${MC_FLAVOUR}/custom/ ]; then |
37 | install -d ${DEPLOYDIR}/mc-utils/custom | 41 | install -d ${DEPLOYDIR}/mc-utils/custom |
38 | cp -r ${S}/config/${MC_CFG}/RDB/custom/*.dtb ${DEPLOYDIR}/mc-utils/custom | 42 | cp -r ${S}/config/${MC_CFG}/${MC_FLAVOUR}/custom/*.dtb ${DEPLOYDIR}/mc-utils/custom |
39 | fi | 43 | fi |
40 | } | 44 | } |
41 | addtask deploy after do_install | 45 | addtask deploy after do_install |
42 | 46 | ||