diff options
author | Chunrong Guo <chunrong.guo@nxp.com> | 2018-01-30 17:09:55 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2018-02-06 09:58:34 -0200 |
commit | 9bb394fea0894a5d1aa95b7ab5ea7301831cd3b9 (patch) | |
tree | d90379618c200a0d910567dd9f54a4e27d896bdd /recipes-bsp/mc-utils | |
parent | b11e8f95428835699ebb44c948fe11dc333e8cb4 (diff) | |
download | meta-freescale-9bb394fea0894a5d1aa95b7ab5ea7301831cd3b9.tar.gz |
mc-utils: add recipes
*include the following changes:
b79fe4b - config: add descriptions to DPCs and DPLs
cc37a9c - config: convert files from dos format to unix
8b3fe8c - config: update source files to match release LSDK-17.09
5b25be0 - config: update source files to match release LSDK-17.06
01a71bb - config: update source files to match LSDK-17.06-EAR
06dda1d - config: add source files for DPLs and DPCs
86da1cf - initial commit
Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/mc-utils')
-rw-r--r-- | recipes-bsp/mc-utils/mc-utils_git.bb | 39 |
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-bsp/mc-utils/mc-utils_git.bb b/recipes-bsp/mc-utils/mc-utils_git.bb new file mode 100644 index 00000000..221c9e2d --- /dev/null +++ b/recipes-bsp/mc-utils/mc-utils_git.bb | |||
@@ -0,0 +1,39 @@ | |||
1 | DESCRIPTION = "The Management Complex (MC) is a key component of DPAA" | ||
2 | SECTION = "mc-utils" | ||
3 | LICENSE = "BSD" | ||
4 | |||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=386a6287daa6504b7e7e5014ddfb3987 \ | ||
6 | " | ||
7 | |||
8 | DEPENDS += "dtc-native" | ||
9 | |||
10 | inherit deploy | ||
11 | |||
12 | SRC_URI = "git://github.com/qoriq-open-source/mc-utils.git;nobranch=1" | ||
13 | SRCREV = "b79fe4b47364dfd2fe263f701ad6b818a75b036b" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | MC_CFG ?= "" | ||
18 | MC_CFG_ls1088a = "ls1088a" | ||
19 | MC_CFG_ls2088a = "ls2088a" | ||
20 | |||
21 | do_install () { | ||
22 | oe_runmake -C config | ||
23 | |||
24 | install -d ${D}/boot/mc-utils/custom | ||
25 | cp -r ${S}/config/${MC_CFG}/RDB/*.dtb ${D}/boot/mc-utils | ||
26 | cp -r ${S}/config/${MC_CFG}/RDB/custom/*.dtb ${D}/boot/mc-utils/custom | ||
27 | } | ||
28 | |||
29 | do_deploy () { | ||
30 | install -d ${DEPLOYDIR}/mc-utils/custom | ||
31 | cp -r ${S}/config/${MC_CFG}/RDB/*.dtb ${DEPLOYDIR}/mc-utils | ||
32 | cp -r ${S}/config/${MC_CFG}/RDB/custom/*.dtb ${DEPLOYDIR}/mc-utils/custom | ||
33 | |||
34 | } | ||
35 | addtask deploy after do_install | ||
36 | |||
37 | PACKAGES += "${PN}-image" | ||
38 | FILES_${PN}-image += "/boot" | ||
39 | COMPATIBLE_MACHINE = "(ls1088a|ls2088a)" | ||