summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/mc-utils/mc-utils_git.bb
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2019-01-11 03:14:02 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2019-01-14 16:23:38 -0200
commit4babcb9d184254805df479695f8bec1e33b447c2 (patch)
tree1e9a1f865d262c4685b1a35eede1f029b7fe0954 /recipes-bsp/mc-utils/mc-utils_git.bb
parent69e44c7b4bba49899c96430f1741e3c56701068e (diff)
downloadmeta-freescale-4babcb9d184254805df479695f8bec1e33b447c2.tar.gz
mc-utils: update to 6aca560
*update to lsdk 1812 tag include the following changes: update COMPATIBLE_MACHINE for qoriq-arm64 6aca560 - config: lx2160a: add dprtc object 73eec5c - api: add MC 10.13.0 APIs 022adf2 - api: add MC 10.12.0 APIs f3e4205 - api: add MC 10.11.2 APIs cb2afb7 - api: add MC 10.11.1 APIs 65aeed6 - config: update number of necessary dpmcp 1370e38 - Add dpc with USXGMII for QDS protocol 7 *Update COMPATIBLE_MACHINE for qoriq-arm64 *Support lx2160a Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Diffstat (limited to 'recipes-bsp/mc-utils/mc-utils_git.bb')
-rw-r--r--recipes-bsp/mc-utils/mc-utils_git.bb20
1 files changed, 13 insertions, 7 deletions
diff --git a/recipes-bsp/mc-utils/mc-utils_git.bb b/recipes-bsp/mc-utils/mc-utils_git.bb
index f34d4418..430d6cd8 100644
--- a/recipes-bsp/mc-utils/mc-utils_git.bb
+++ b/recipes-bsp/mc-utils/mc-utils_git.bb
@@ -10,30 +10,36 @@ DEPENDS += "dtc-native"
10inherit deploy 10inherit deploy
11 11
12SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/mc-utils;nobranch=1" 12SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/mc-utils;nobranch=1"
13SRCREV = "30c63101b15def4620f509641b97641c25fe19fe" 13SRCREV = "6aca560c630dc54afdef382c506f214b28f4985e"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
17MC_CFG ?= "" 17MC_CFG ?= ""
18MC_CFG_ls1088a = "ls1088a" 18MC_CFG_ls1088a = "ls1088a"
19MC_CFG_ls2088a = "ls2088a" 19MC_CFG_ls2088a = "ls2088a"
20MC_CFG_lx2160a = "lx2160a"
20 21
21do_install () { 22do_install () {
22 oe_runmake -C config 23 oe_runmake -C config
23 24
24 install -d ${D}/boot/mc-utils/custom 25 install -d ${D}/boot/mc-utils
25 cp -r ${S}/config/${MC_CFG}/RDB/*.dtb ${D}/boot/mc-utils 26 cp -r ${S}/config/${MC_CFG}/RDB/*.dtb ${D}/boot/mc-utils
26 cp -r ${S}/config/${MC_CFG}/RDB/custom/*.dtb ${D}/boot/mc-utils/custom 27 if [ -d ${S}/config/${MC_CFG}/RDB/custom/ ]; then
28 install -d ${D}/boot/mc-utils/custom
29 cp -r ${S}/config/${MC_CFG}/RDB/custom/*.dtb ${D}/boot/mc-utils/custom
30 fi
27} 31}
28 32
29do_deploy () { 33do_deploy () {
30 install -d ${DEPLOYDIR}/mc-utils/custom 34 install -d ${DEPLOYDIR}/mc-utils
31 cp -r ${S}/config/${MC_CFG}/RDB/*.dtb ${DEPLOYDIR}/mc-utils 35 cp -r ${S}/config/${MC_CFG}/RDB/*.dtb ${DEPLOYDIR}/mc-utils
32 cp -r ${S}/config/${MC_CFG}/RDB/custom/*.dtb ${DEPLOYDIR}/mc-utils/custom 36 if [ -d ${S}/config/${MC_CFG}/RDB/custom/ ]; then
33 37 install -d ${DEPLOYDIR}/mc-utils/custom
38 cp -r ${S}/config/${MC_CFG}/RDB/custom/*.dtb ${DEPLOYDIR}/mc-utils/custom
39 fi
34} 40}
35addtask deploy after do_install 41addtask deploy after do_install
36 42
37PACKAGES += "${PN}-image" 43PACKAGES += "${PN}-image"
38FILES_${PN}-image += "/boot" 44FILES_${PN}-image += "/boot"
39COMPATIBLE_MACHINE = "(ls1088a|ls2088a)" 45COMPATIBLE_MACHINE = "(qoriq-arm64)"