summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/ls2-phy
diff options
context:
space:
mode:
authorZongchun Yu <zongchun.yu@nxp.com>2016-07-16 00:28:39 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-07-22 11:30:51 -0300
commite33faea587752329cdaa4643155a5a0e24f35938 (patch)
tree98eb5c80ea245cbabdb9f234dfea4798fc3b5174 /recipes-bsp/ls2-phy
parente347d641489a5c67c4ae014db3368ed77f254375 (diff)
downloadmeta-freescale-e33faea587752329cdaa4643155a5a0e24f35938.tar.gz
ls2-phy: Add recipe
Signed-off-by: Zongchun Yu <zongchun.yu@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/ls2-phy')
-rw-r--r--recipes-bsp/ls2-phy/ls2-phy_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-bsp/ls2-phy/ls2-phy_git.bb b/recipes-bsp/ls2-phy/ls2-phy_git.bb
new file mode 100644
index 00000000..422a922e
--- /dev/null
+++ b/recipes-bsp/ls2-phy/ls2-phy_git.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Firmwares and Standalone Applications"
2LICENSE = "Freescale-EULA"
3LIC_FILES_CHKSUM = "file://EULA;md5=c9ae442cf1f9dd6c13dfad64b0ffe73f"
4
5inherit deploy
6
7SRC_URI = "git://git.freescale.com/ppc/sdk/ls2-phy.git;branch=sdk-v2.0.x"
8SRCREV = "554f2648c6a4c6f974827ab326e8c1908dead6f1"
9
10S = "${WORKDIR}/git"
11
12do_install () {
13 install -d ${D}/boot
14 cp -fr ${S}/AQR405 ${D}/boot
15 cp -fr ${S}/CS4340 ${D}/boot
16}
17
18do_deploy () {
19 install -d ${DEPLOYDIR}/ls2-phy
20 cp -fr ${S}/AQR405 ${DEPLOYDIR}/ls2-phy
21 cp -fr ${S}/CS4340 ${DEPLOYDIR}/ls2-phy
22}
23addtask deploy before do_build after do_install
24
25PACKAGES += "${PN}-image"
26FILES_${PN}-image += "/boot"
27COMPATIBLE_MACHINE = "(ls2080ardb)"