diff options
author | Carlos Rafael Giani <crg7475@mailbox.org> | 2020-04-18 20:00:39 +0200 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-04-20 16:17:28 -0300 |
commit | 439117a682be26997c11c27d4acc55276aa547b7 (patch) | |
tree | 70f230e474c0e3eb4a8d7869af55e61be11a9970 /recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb | |
parent | 91156d78b379334c5eb714cf0029ee2a5edfe732 (diff) | |
download | meta-freescale-439117a682be26997c11c27d4acc55276aa547b7.tar.gz |
libimxdmabuffer: Upgrade to version 1.0.1
* Changes to migrate build system to Python 3:
* waf: update to 2.0.12
* waf: use python3
Signed-off-by: Carlos Rafael Giani <crg7475@mailbox.org>
Diffstat (limited to 'recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb')
-rw-r--r-- | recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb new file mode 100644 index 00000000..346a3cf5 --- /dev/null +++ b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | DESCRIPTION = 'Library for allocating and managing physically contiguous memory \ | ||
2 | ("DMA memory" or "DMA buffers") on i.MX devices.' | ||
3 | HOMEPAGE = "https://github.com/Freescale/libimxdmabuffer" | ||
4 | LICENSE = "LGPLv2.1" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=38fa42a5a6425b26d2919b17b1527324" | ||
6 | SECTION = "base" | ||
7 | |||
8 | PV .= "+git${SRCPV}" | ||
9 | |||
10 | SRCBRANCH ?= "master" | ||
11 | SRCREV = "d2058aa404ee1e8e8abd552c6a637787bcdcf514" | ||
12 | SRC_URI = "git://github.com/Freescale/libimxdmabuffer.git;branch=${SRCBRANCH}" | ||
13 | |||
14 | S = "${WORKDIR}/git" | ||
15 | |||
16 | inherit pkgconfig waf use-imx-headers ptest | ||
17 | |||
18 | EXTRA_OECONF = "--imx-linux-headers-path=${STAGING_INCDIR_IMX} \ | ||
19 | --libdir=${libdir} \ | ||
20 | ${PACKAGECONFIG_CONFARGS}" | ||
21 | |||
22 | PACKAGECONFIG ?= " " | ||
23 | PACKAGECONFIG_append_imxgpu2d = " g2d" | ||
24 | PACKAGECONFIG_append_imxipu = " ipu" | ||
25 | PACKAGECONFIG_append_imxpxp = " pxp" | ||
26 | PACKAGECONFIG_append_mx8m = " dwl ion" | ||
27 | |||
28 | HANTRO_CONF = "--hantro-headers-path=${STAGING_INCDIR}/hantro_dec --hantro-decoder-version=G2" | ||
29 | |||
30 | PACKAGECONFIG[dwl] = "--with-dwl-allocator=yes ${HANTRO_CONF},--with-dwl-allocator=no,imx-vpu-hantro" | ||
31 | PACKAGECONFIG[ion] = "--with-ion-allocator=yes, --with-ion-allocator=no," | ||
32 | PACKAGECONFIG[ipu] = "--with-ipu-allocator=yes, --with-ipu-allocator=no," | ||
33 | PACKAGECONFIG[g2d] = "--with-g2d-allocator=yes, --with-g2d-allocator=no,virtual/libg2d" | ||
34 | PACKAGECONFIG[pxp] = "--with-pxp-allocator=yes, --with-pxp-allocator=no," | ||
35 | |||
36 | do_install_ptest () { | ||
37 | install -d ${D}${PTEST_PATH}/tests | ||
38 | install -m 0755 ${B}/test-alloc ${D}${PTEST_PATH}/tests | ||
39 | } | ||
40 | |||
41 | COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" | ||