summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/isp-imx
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2021-04-27 17:43:51 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2021-04-30 15:09:16 -0300
commiteeef41ee74fffe455cc9c9b8d65443da40c69030 (patch)
tree30f3ecfd9a8a0ddc73137e47735b39ebc3d822ac /recipes-bsp/isp-imx
parentaeb17125b4e3d6b1f390271a389c70dc4c615400 (diff)
downloadmeta-freescale-eeef41ee74fffe455cc9c9b8d65443da40c69030.tar.gz
isp-imx: Cleanup recipe
Fix variable order, use BP in place of BPN-PV and PN-PV. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp/isp-imx')
-rw-r--r--recipes-bsp/isp-imx/isp-imx_4.2.2.11.0.bb20
1 files changed, 10 insertions, 10 deletions
diff --git a/recipes-bsp/isp-imx/isp-imx_4.2.2.11.0.bb b/recipes-bsp/isp-imx/isp-imx_4.2.2.11.0.bb
index b106b985..5f33e78b 100644
--- a/recipes-bsp/isp-imx/isp-imx_4.2.2.11.0.bb
+++ b/recipes-bsp/isp-imx/isp-imx_4.2.2.11.0.bb
@@ -3,21 +3,21 @@
3DESCRIPTION = "i.MX Verisilicon Software ISP" 3DESCRIPTION = "i.MX Verisilicon Software ISP"
4LICENSE = "Proprietary" 4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=3c3fe2b904fd694f28d2f646ee16dddb" 5LIC_FILES_CHKSUM = "file://COPYING;md5=3c3fe2b904fd694f28d2f646ee16dddb"
6DEPENDS = "python3 libdrm"
6 7
7inherit fsl-eula-unpack cmake systemd 8SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true \
8
9SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true \
10 file://0001-start_isp.sh-fix-test-to-be-generic.patch \ 9 file://0001-start_isp.sh-fix-test-to-be-generic.patch \
11" 10"
12 11
13SRC_URI[md5sum] = "75f79ba556c47172b9a0cbc3a877e604" 12SRC_URI[md5sum] = "75f79ba556c47172b9a0cbc3a877e604"
14SRC_URI[sha256sum] = "28e2ee909f29a256c4eac87ef8336932d90a88a2a183389ac0868212954af42c" 13SRC_URI[sha256sum] = "28e2ee909f29a256c4eac87ef8336932d90a88a2a183389ac0868212954af42c"
15 14
16DEPENDS = "python3 libdrm" 15inherit fsl-eula-unpack cmake systemd
17 16
18# Build the sub-folder appshell 17# Build the sub-folder appshell
19OECMAKE_SOURCEPATH = "${S}/appshell" 18OECMAKE_SOURCEPATH = "${S}/appshell"
20 19
20# Use make instead of ninja
21OECMAKE_GENERATOR = "Unix Makefiles" 21OECMAKE_GENERATOR = "Unix Makefiles"
22 22
23SYSTEMD_SERVICE_${PN} = "imx8-isp.service" 23SYSTEMD_SERVICE_${PN} = "imx8-isp.service"
@@ -52,24 +52,22 @@ do_install() {
52 cp -r ${WORKDIR}/build/generated/release/bin/*2775* ${D}/opt/imx8-isp/bin 52 cp -r ${WORKDIR}/build/generated/release/bin/*2775* ${D}/opt/imx8-isp/bin
53 cp -r ${WORKDIR}/build/generated/release/bin/isp_media_server ${D}/opt/imx8-isp/bin 53 cp -r ${WORKDIR}/build/generated/release/bin/isp_media_server ${D}/opt/imx8-isp/bin
54 cp -r ${WORKDIR}/build/generated/release/bin/vvext ${D}/opt/imx8-isp/bin 54 cp -r ${WORKDIR}/build/generated/release/bin/vvext ${D}/opt/imx8-isp/bin
55 cp -r ${WORKDIR}/${PN}-${PV}/mediacontrol/case/ ${D}/opt/imx8-isp/bin 55 cp -r ${WORKDIR}/${BP}/mediacontrol/case/ ${D}/opt/imx8-isp/bin
56 cp -r ${WORKDIR}/build/generated/release/lib/*.so* ${D}/${libdir} 56 cp -r ${WORKDIR}/build/generated/release/lib/*.so* ${D}/${libdir}
57 cp -r ${WORKDIR}/build/generated/release/include/* ${D}/${includedir} 57 cp -r ${WORKDIR}/build/generated/release/include/* ${D}/${includedir}
58 58
59 cp ${WORKDIR}/${PN}-${PV}/imx/run.sh ${D}/opt/imx8-isp/bin 59 cp ${WORKDIR}/${BP}/imx/run.sh ${D}/opt/imx8-isp/bin
60 cp ${WORKDIR}/${PN}-${PV}/imx/start_isp.sh ${D}/opt/imx8-isp/bin 60 cp ${WORKDIR}/${BP}/imx/start_isp.sh ${D}/opt/imx8-isp/bin
61 61
62 chmod +x ${D}/opt/imx8-isp/bin/run.sh 62 chmod +x ${D}/opt/imx8-isp/bin/run.sh
63 chmod +x ${D}/opt/imx8-isp/bin/start_isp.sh 63 chmod +x ${D}/opt/imx8-isp/bin/start_isp.sh
64 64
65 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then 65 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
66 install -d ${D}${systemd_system_unitdir} 66 install -d ${D}${systemd_system_unitdir}
67 install -m 0644 ${WORKDIR}/${PN}-${PV}/imx/imx8-isp.service ${D}${systemd_system_unitdir} 67 install -m 0644 ${WORKDIR}/${BP}/imx/imx8-isp.service ${D}${systemd_system_unitdir}
68 fi 68 fi
69} 69}
70 70
71RDEPENDS_${PN} = "libdrm libpython3"
72
73# The build contains a mix of versioned and unversioned libraries, so 71# The build contains a mix of versioned and unversioned libraries, so
74# the default packaging configuration needs some modifications 72# the default packaging configuration needs some modifications
75FILES_SOLIBSDEV = "" 73FILES_SOLIBSDEV = ""
@@ -82,4 +80,6 @@ FILES_${PN}-dev += " \
82 80
83INSANE_SKIP_${PN} = "rpaths" 81INSANE_SKIP_${PN} = "rpaths"
84 82
83RDEPENDS_${PN} = "libdrm libpython3"
84
85COMPATIBLE_MACHINE = "(imx|use-nxp-bsp)" 85COMPATIBLE_MACHINE = "(imx|use-nxp-bsp)"