summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/isp-imx
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2021-04-27 17:14:29 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2021-04-30 15:09:16 -0300
commit5910cd66fc290842218a17efffb4433026b27a52 (patch)
tree45f6b017f94ed5e35ac831c1834274cd02a34892 /recipes-bsp/isp-imx
parent0b4784363e8fffec063249b54837b1f08536d536 (diff)
downloadmeta-freescale-5910cd66fc290842218a17efffb4433026b27a52.tar.gz
isp-imx: Normalize the recipe source folder
The source folder of the recipe is adjusted to the appshell sub-folder to facilitate building of that folder. This causes complicated adjustments for the license and patch files. Restore the source folder to the default and use OECMAKE_SOURCEPATH to direct the build to the appshell sub-folder. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp/isp-imx')
-rw-r--r--recipes-bsp/isp-imx/isp-imx_4.2.2.11.0.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/recipes-bsp/isp-imx/isp-imx_4.2.2.11.0.bb b/recipes-bsp/isp-imx/isp-imx_4.2.2.11.0.bb
index 1e363d13..53894baf 100644
--- a/recipes-bsp/isp-imx/isp-imx_4.2.2.11.0.bb
+++ b/recipes-bsp/isp-imx/isp-imx_4.2.2.11.0.bb
@@ -2,21 +2,22 @@
2 2
3DESCRIPTION = "i.MX Verisilicon Software ISP" 3DESCRIPTION = "i.MX Verisilicon Software ISP"
4LICENSE = "Proprietary" 4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://${WORKDIR}/${PN}-${PV}/COPYING;md5=3c3fe2b904fd694f28d2f646ee16dddb" 5LIC_FILES_CHKSUM = "file://COPYING;md5=3c3fe2b904fd694f28d2f646ee16dddb"
6 6
7inherit fsl-eula-unpack cmake systemd 7inherit fsl-eula-unpack cmake systemd
8 8
9SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true \ 9SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true \
10 file://0001-start_isp.sh-fix-test-to-be-generic.patch;patchdir=.. \ 10 file://0001-start_isp.sh-fix-test-to-be-generic.patch \
11" 11"
12 12
13SRC_URI[md5sum] = "75f79ba556c47172b9a0cbc3a877e604" 13SRC_URI[md5sum] = "75f79ba556c47172b9a0cbc3a877e604"
14SRC_URI[sha256sum] = "28e2ee909f29a256c4eac87ef8336932d90a88a2a183389ac0868212954af42c" 14SRC_URI[sha256sum] = "28e2ee909f29a256c4eac87ef8336932d90a88a2a183389ac0868212954af42c"
15 15
16S = "${WORKDIR}/${PN}-${PV}/appshell"
17
18DEPENDS = "python3 libdrm" 16DEPENDS = "python3 libdrm"
19 17
18# Build the sub-folder appshell
19OECMAKE_SOURCEPATH = "${S}/appshell"
20
20OECMAKE_GENERATOR = "Unix Makefiles" 21OECMAKE_GENERATOR = "Unix Makefiles"
21 22
22SYSTEMD_SERVICE_${PN} = "imx8-isp.service" 23SYSTEMD_SERVICE_${PN} = "imx8-isp.service"