summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/isp-imx/isp-imx_4.2.2.13.0.bb
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2021-07-28 14:25:33 -0500
committerDaiane Angolini <daiane.angolini@foundries.io>2021-09-11 13:35:14 -0300
commitd9160df622275b955a7f52cc1ba385cd94a949e0 (patch)
treed810f40cf0b0a5d6cba867b6a5d97e4b5949d011 /recipes-bsp/isp-imx/isp-imx_4.2.2.13.0.bb
parent0e06a2f532e61e8a7e7e85c3440130386bc43114 (diff)
downloadmeta-freescale-d9160df622275b955a7f52cc1ba385cd94a949e0.tar.gz
isp-imx: Upgrade to 4.2.2.13.0
a52c0446d change version number to p13 800e0f8d8 Fix M865SW-753:copy sensor init txt just for native a4210be47 remove unused VVCAM_PARAMS ad8728441 add dual basler camera mode 4 for 1080p25hdr eea1908b8 cleanup the build script da5bd492b remove vvnative which is only for local test c725c6266 Revert "cleanup for unused config file" a399dbd70 cleanup for unused config file 1bd986e2d Remove basler binary driver from source build 98ef8c98a New partial build partial_release_20210430_4.2.2_p12 31d26c84d Update Release P12 from Verisilicon c82e5b9bb limit basler camera resolution to 1080p when ov5640 is also used 8c9825a6d add a trailing '/' for file search in directory f101a6a64 Update Release form Verisilicon fbfe4fda0 add a blank line for good readability 91663d97c enlarge the StartLimitBurst 0c3dc6a6e add explanatory to the tunning example for video_test 365e7f8f5 BSLRM865-124: improve the running example for video_test 253818b3f Segment error caused by DTS modification a8a906d4d M865SW-703 Use reversed memory only for tuning tool 7c40835b2 Remove basler binary driver from source build 9bf7ff1ba BSLRM865-131 fix crop seems scale aee50d3d0 imx8-isp.service: do not prevent restart of service 3232149ac run.sh: fix bashism 5fbf584d2 Removing action for copying run-imx.sh as it's gone 860346a5d Update Release form Verisilicon f5b3c8783 MLK-25354 add user description for dual basler cameras 85ab6c183 update run script to work with P10/P11 19fb6591b update run script to same as P6 daba60f02 update Release form Verisilicon Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp/isp-imx/isp-imx_4.2.2.13.0.bb')
-rw-r--r--recipes-bsp/isp-imx/isp-imx_4.2.2.13.0.bb86
1 files changed, 86 insertions, 0 deletions
diff --git a/recipes-bsp/isp-imx/isp-imx_4.2.2.13.0.bb b/recipes-bsp/isp-imx/isp-imx_4.2.2.13.0.bb
new file mode 100644
index 00000000..ec15dfb9
--- /dev/null
+++ b/recipes-bsp/isp-imx/isp-imx_4.2.2.13.0.bb
@@ -0,0 +1,86 @@
1# Copyright 2020-2021 NXP
2
3DESCRIPTION = "i.MX Verisilicon Software ISP"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=417b82f17fc02b88125331ed312f6f1b"
6DEPENDS = "python3 libdrm virtual/libg2d"
7
8SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true \
9 file://0001-start_isp.sh-fix-test-to-be-generic.patch \
10"
11
12SRC_URI[md5sum] = "123feed48302fea2a1be8572e913ae47"
13SRC_URI[sha256sum] = "e775975684aab4211f0bf8c5e2c6604ba46b83c5586937000675e044a50d77b8"
14
15inherit fsl-eula-unpack cmake systemd use-imx-headers
16
17# Build the sub-folder appshell
18OECMAKE_SOURCEPATH = "${S}/appshell"
19
20# Use make instead of ninja
21OECMAKE_GENERATOR = "Unix Makefiles"
22
23SYSTEMD_SERVICE_${PN} = "imx8-isp.service"
24
25EXTRA_OECMAKE += " \
26 -DCMAKE_BUILD_TYPE=release \
27 -DISP_VERSION=ISP8000NANO_V1802 \
28 -DPLATFORM=ARM64 \
29 -DAPPMODE=V4L2 \
30 -DQTLESS=1 \
31 -DFULL_SRC_COMPILE=1 \
32 -DWITH_DRM=1 \
33 -DWITH_DWE=1 \
34 -DSERVER_LESS=1 \
35 -DSUBDEV_V4L2=1 \
36 -DENABLE_IRQ=1 \
37 -DPARTITION_BUILD=0 \
38 -D3A_SRC_BUILD=0 \
39 -DIMX_G2D=ON \
40 -Wno-dev \
41"
42
43do_configure_prepend() {
44 export SDKTARGETSYSROOT=${STAGING_DIR_HOST}
45}
46
47do_install() {
48 install -d ${D}/${libdir}
49 install -d ${D}/${includedir}
50 install -d ${D}/opt/imx8-isp/bin
51
52 cp -r ${WORKDIR}/build/generated/release/bin/*_test ${D}/opt/imx8-isp/bin
53 cp -r ${WORKDIR}/build/generated/release/bin/*2775* ${D}/opt/imx8-isp/bin
54 cp -r ${WORKDIR}/build/generated/release/bin/isp_media_server ${D}/opt/imx8-isp/bin
55 cp -r ${WORKDIR}/build/generated/release/bin/vvext ${D}/opt/imx8-isp/bin
56 cp -r ${WORKDIR}/${BP}/dewarp/dewarp_config/ ${D}/opt/imx8-isp/bin
57 cp -r ${WORKDIR}/build/generated/release/lib/*.so* ${D}/${libdir}
58 cp -r ${WORKDIR}/build/generated/release/include/* ${D}/${includedir}
59
60 cp ${WORKDIR}/${BP}/imx/run.sh ${D}/opt/imx8-isp/bin
61 cp ${WORKDIR}/${BP}/imx/start_isp.sh ${D}/opt/imx8-isp/bin
62
63 chmod +x ${D}/opt/imx8-isp/bin/run.sh
64 chmod +x ${D}/opt/imx8-isp/bin/start_isp.sh
65
66 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
67 install -d ${D}${systemd_system_unitdir}
68 install -m 0644 ${WORKDIR}/${BP}/imx/imx8-isp.service ${D}${systemd_system_unitdir}
69 fi
70}
71
72# The build contains a mix of versioned and unversioned libraries, so
73# the default packaging configuration needs some modifications
74FILES_SOLIBSDEV = ""
75FILES_${PN} += "/opt ${libdir}/lib*${SOLIBSDEV}"
76FILES_${PN}-dev += " \
77 ${libdir}/libjsoncpp.so \
78 ${libdir}/libos08a20.so \
79 ${libdir}/libov2775.so \
80"
81
82INSANE_SKIP_${PN} = "rpaths"
83
84RDEPENDS_${PN} = "libdrm libpython3"
85
86COMPATIBLE_MACHINE = "(mx8mp)"