diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-15 17:14:27 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-16 15:01:29 -0300 |
commit | f8517afc7a5ada4538b3b7d397fa32586d57ffe5 (patch) | |
tree | 79349f091306d1760fd4687e62336ffa8fb8c721 /recipes-bsp/imx-vpu | |
parent | c92b415d653afc55f33b6b93fb9248193bfd4fa0 (diff) | |
download | meta-freescale-f8517afc7a5ada4538b3b7d397fa32586d57ffe5.tar.gz |
Move meta-fsl-arm content to layer root
The meta-fsl-arm is going to be used as the base for this layer. It
contains a clean history and allowing a more granullar set of changes.
This commit is just a rename of all contents of meta-fsl-arm
subdirectory to this layer's root, subsequent changes are based on top
of that.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/imx-vpu')
-rw-r--r-- | recipes-bsp/imx-vpu/imx-vpu-11.09.02/obey-variables.patch | 27 | ||||
-rw-r--r-- | recipes-bsp/imx-vpu/imx-vpu.inc | 22 | ||||
-rw-r--r-- | recipes-bsp/imx-vpu/imx-vpu_11.09.02.bb | 8 | ||||
-rw-r--r-- | recipes-bsp/imx-vpu/imx-vpu_5.4.28.bb | 12 |
4 files changed, 69 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu/imx-vpu-11.09.02/obey-variables.patch b/recipes-bsp/imx-vpu/imx-vpu-11.09.02/obey-variables.patch new file mode 100644 index 00000000..13f61b27 --- /dev/null +++ b/recipes-bsp/imx-vpu/imx-vpu-11.09.02/obey-variables.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | Obey CFLAGS, LDFLAGS | ||
2 | |||
3 | Signed-off-by: Christopher Larson <chris_larson@mentor.com> | ||
4 | Upstream-status: Pending | ||
5 | |||
6 | --- imx-vpu-11.09.02.orig/vpu/Makefile 2014-09-02 13:14:50.862005896 -0700 | ||
7 | +++ imx-vpu-11.09.02/vpu/Makefile 2014-09-02 13:15:15.018153222 -0700 | ||
8 | @@ -1,5 +1,6 @@ | ||
9 | CC ?=$(CROSS_COMPILE)gcc | ||
10 | AR ?=$(CROSS_COMPILE)ar | ||
11 | +CFLAGS ?= -O2 | ||
12 | |||
13 | # list of platforms which want this test case | ||
14 | INCLUDE_LIST:= IMX27ADS IMX51 IMX53 IMX6Q | ||
15 | @@ -33,10 +34,10 @@ | ||
16 | endif | ||
17 | |||
18 | %.o: %.c | ||
19 | - $(CC) -D$(PLATFORM) -Wall -O2 -fPIC -c $^ -o $@ | ||
20 | + $(CC) -D$(PLATFORM) -Wall -fPIC $(CFLAGS) -c $^ -o $@ | ||
21 | |||
22 | $(LIBNAME).so.$(SONAMEVERSION): $(OBJ) | ||
23 | - $(CC) -shared -nostartfiles -Wl,-soname,$@ $^ -o $@ | ||
24 | + $(CC) -shared -nostartfiles -Wl,-soname,$@ $^ -o $@ $(LDFLAGS) | ||
25 | |||
26 | $(LIBNAME).so: $(LIBNAME).so.$(SONAMEVERSION) | ||
27 | ln -s $< $@ | ||
diff --git a/recipes-bsp/imx-vpu/imx-vpu.inc b/recipes-bsp/imx-vpu/imx-vpu.inc new file mode 100644 index 00000000..fd59770a --- /dev/null +++ b/recipes-bsp/imx-vpu/imx-vpu.inc | |||
@@ -0,0 +1,22 @@ | |||
1 | # Copyright (C) 2013 Freescale Semiconductor | ||
2 | DESCRIPTION = "Freescale VPU library" | ||
3 | LICENSE = "Proprietary" | ||
4 | LIC_FILES_CHKSUM = "file://vpu/EULA.txt;md5=b063366b066c9f10037c59756a9ced54" | ||
5 | DEPENDS = "virtual/kernel" | ||
6 | inherit fsl-eula-unpack | ||
7 | |||
8 | PLATFORM_mx5 = "IMX51" | ||
9 | PLATFORM_mx6 = "IMX6Q" | ||
10 | |||
11 | SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true" | ||
12 | |||
13 | do_compile () { | ||
14 | INCLUDE_DIR="-I${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include" | ||
15 | |||
16 | oe_runmake CROSS_COMPILE="${HOST_PREFIX}" PLATFORM="${PLATFORM}" INCLUDE="${INCLUDE_DIR}" all | ||
17 | } | ||
18 | |||
19 | do_install () { | ||
20 | oe_runmake PLATFORM="${PLATFORM}" DEST_DIR="${D}" install | ||
21 | } | ||
22 | |||
diff --git a/recipes-bsp/imx-vpu/imx-vpu_11.09.02.bb b/recipes-bsp/imx-vpu/imx-vpu_11.09.02.bb new file mode 100644 index 00000000..c5dd9bd5 --- /dev/null +++ b/recipes-bsp/imx-vpu/imx-vpu_11.09.02.bb | |||
@@ -0,0 +1,8 @@ | |||
1 | # Copyright (C) 2013 Freescale Semiconductor | ||
2 | require imx-vpu.inc | ||
3 | |||
4 | SRC_URI += "file://obey-variables.patch" | ||
5 | SRC_URI[md5sum] = "1988a08687a09ef8590e66ff17ac6ed3" | ||
6 | SRC_URI[sha256sum] = "783f136aa9b9257d4bffbdaf05bdcb85d177c544c3f8a4674421ba7b065ed5c0" | ||
7 | |||
8 | COMPATIBLE_MACHINE = "(mx5)" | ||
diff --git a/recipes-bsp/imx-vpu/imx-vpu_5.4.28.bb b/recipes-bsp/imx-vpu/imx-vpu_5.4.28.bb new file mode 100644 index 00000000..6f691562 --- /dev/null +++ b/recipes-bsp/imx-vpu/imx-vpu_5.4.28.bb | |||
@@ -0,0 +1,12 @@ | |||
1 | # Copyright (C) 2013-2015 Freescale Semiconductor | ||
2 | |||
3 | require imx-vpu.inc | ||
4 | |||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=acdb807ac7275fe32f9f64992e111241" | ||
6 | |||
7 | PE = "1" | ||
8 | |||
9 | SRC_URI[md5sum] = "774455b57aaa12bae2e2cecf39b63ac4" | ||
10 | SRC_URI[sha256sum] = "0a05af1a5978175de852b2cf61763ec789f2845df78edb8d02a28611439b57f7" | ||
11 | |||
12 | COMPATIBLE_MACHINE = "(mx6)" | ||