summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-08-05 08:50:26 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2016-04-19 15:03:14 -0300
commitd5e730317a4d1aa94bdfbf25654847fe788d70df (patch)
tree36c4c98296a7c073fa66a9bf938343ba63a9cf91 /recipes-bsp/imx-vpu
parentb33e2a1f77655f625f3a4477a345991310af615b (diff)
downloadmeta-freescale-d5e730317a4d1aa94bdfbf25654847fe788d70df.tar.gz
Drop Freescale official Linux kernel for i.MX23, i.MX28 and i.MX5 SoC families
The Linux kernel provided by Freescale for i.MX28 and i.MX5 is too old (2.6.35.3) and there are no plans to upgrade it, as the OE-Core is going to use GCC 5.2 as default compiler soon and it is not possible to compile this kernel with the new toolchain, thus the removal. The metadata related to the i.MX23, i.MX28 and i.MX5 SoC family, which is dependant of this Linux kernel support, has been removed in this commit so if someone ever wants to bring it back it is easy to find out all the necessary changes. The recipes affected are: - alsa-state - amd-gpu-x11-bin - gtk+3 - imx-lib - imx-test - imx-vpu - libfslcodec - linux-imx - mesa - qt4-embedded-free - qt4-x11-free - qtbase - xf86-video-imxfb Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Acked-by: Daiane Angolini <daiane.angolini@freescale.com>
Diffstat (limited to 'recipes-bsp/imx-vpu')
-rw-r--r--recipes-bsp/imx-vpu/imx-vpu-11.09.02/obey-variables.patch27
-rw-r--r--recipes-bsp/imx-vpu/imx-vpu.inc1
-rw-r--r--recipes-bsp/imx-vpu/imx-vpu_11.09.02.bb8
3 files changed, 0 insertions, 36 deletions
diff --git a/recipes-bsp/imx-vpu/imx-vpu-11.09.02/obey-variables.patch b/recipes-bsp/imx-vpu/imx-vpu-11.09.02/obey-variables.patch
deleted file mode 100644
index 13f61b27..00000000
--- a/recipes-bsp/imx-vpu/imx-vpu-11.09.02/obey-variables.patch
+++ /dev/null
@@ -1,27 +0,0 @@
1Obey CFLAGS, LDFLAGS
2
3Signed-off-by: Christopher Larson <chris_larson@mentor.com>
4Upstream-status: Pending
5
6--- imx-vpu-11.09.02.orig/vpu/Makefile 2014-09-02 13:14:50.862005896 -0700
7+++ imx-vpu-11.09.02/vpu/Makefile 2014-09-02 13:15:15.018153222 -0700
8@@ -1,5 +1,6 @@
9 CC ?=$(CROSS_COMPILE)gcc
10 AR ?=$(CROSS_COMPILE)ar
11+CFLAGS ?= -O2
12
13 # list of platforms which want this test case
14 INCLUDE_LIST:= IMX27ADS IMX51 IMX53 IMX6Q
15@@ -33,10 +34,10 @@
16 endif
17
18 %.o: %.c
19- $(CC) -D$(PLATFORM) -Wall -O2 -fPIC -c $^ -o $@
20+ $(CC) -D$(PLATFORM) -Wall -fPIC $(CFLAGS) -c $^ -o $@
21
22 $(LIBNAME).so.$(SONAMEVERSION): $(OBJ)
23- $(CC) -shared -nostartfiles -Wl,-soname,$@ $^ -o $@
24+ $(CC) -shared -nostartfiles -Wl,-soname,$@ $^ -o $@ $(LDFLAGS)
25
26 $(LIBNAME).so: $(LIBNAME).so.$(SONAMEVERSION)
27 ln -s $< $@
diff --git a/recipes-bsp/imx-vpu/imx-vpu.inc b/recipes-bsp/imx-vpu/imx-vpu.inc
index fd59770a..c84bf955 100644
--- a/recipes-bsp/imx-vpu/imx-vpu.inc
+++ b/recipes-bsp/imx-vpu/imx-vpu.inc
@@ -5,7 +5,6 @@ LIC_FILES_CHKSUM = "file://vpu/EULA.txt;md5=b063366b066c9f10037c59756a9ced54"
5DEPENDS = "virtual/kernel" 5DEPENDS = "virtual/kernel"
6inherit fsl-eula-unpack 6inherit fsl-eula-unpack
7 7
8PLATFORM_mx5 = "IMX51"
9PLATFORM_mx6 = "IMX6Q" 8PLATFORM_mx6 = "IMX6Q"
10 9
11SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true" 10SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true"
diff --git a/recipes-bsp/imx-vpu/imx-vpu_11.09.02.bb b/recipes-bsp/imx-vpu/imx-vpu_11.09.02.bb
deleted file mode 100644
index c5dd9bd5..00000000
--- a/recipes-bsp/imx-vpu/imx-vpu_11.09.02.bb
+++ /dev/null
@@ -1,8 +0,0 @@
1# Copyright (C) 2013 Freescale Semiconductor
2require imx-vpu.inc
3
4SRC_URI += "file://obey-variables.patch"
5SRC_URI[md5sum] = "1988a08687a09ef8590e66ff17ac6ed3"
6SRC_URI[sha256sum] = "783f136aa9b9257d4bffbdaf05bdcb85d177c544c3f8a4674421ba7b065ed5c0"
7
8COMPATIBLE_MACHINE = "(mx5)"