summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu-hantro
diff options
context:
space:
mode:
authorYuqing Zhu <carol.zhu@nxp.com>2018-09-30 16:52:37 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-10-01 14:52:55 -0300
commite129edaedde7d4e828e2e186a6d34cb923d38bb9 (patch)
treea7f2683edce43dcc54723aa6757c995808f72c1b /recipes-bsp/imx-vpu-hantro
parent4aa69d60e379a712020acae92be3dda6647c869b (diff)
downloadmeta-freescale-e129edaedde7d4e828e2e186a6d34cb923d38bb9.tar.gz
imx-vpu-hantro: Upgrade version from 1.7.0 to 1.8.0
Add support for i.MX8MMEVK Update EULA to V26 Update ion header inclusion patch Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/imx-vpu-hantro')
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch85
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.8.0.bb (renamed from recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.7.0.bb)10
2 files changed, 65 insertions, 30 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch
index e7b23f7e..27731004 100644
--- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch
@@ -1,41 +1,74 @@
1From 872c82e7cbb9a0a0e761e8ac70fc28e19a55b4c3 Mon Sep 17 00:00:00 2001 1From cf67cfecc01538e32cd99e3ca00ff0e6145079ce Mon Sep 17 00:00:00 2001
2From: Gary Bisson <gary.bisson@boundarydevices.com> 2From: Yuqing Zhu <carol.zhu@nxp.com>
3Date: Thu, 12 Jul 2018 11:38:28 +0200 3Date: Thu, 27 Sep 2018 15:34:11 +0800
4Subject: [PATCH] Fix ion.h header inclusion to be standard 4Subject: [PATCH] imx-vpu-hantro: Fix ion.h header inclusion to be standard
5 5
6NXP "solution" was to manually copy the header to include/linux. 6NXP "solution" was to manually copy the header to include/linux.
7Let's point the Makefile to the proper (mainline) location instead: 7Let's point the Makefile to the proper (mainline) location instead:
8https://elixir.bootlin.com/linux/v4.17/source/drivers/staging/android/uapi/ion.h 8https://elixir.bootlin.com/linux/v4.17/source/drivers/staging/android/uapi/ion.h
9 9
10Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com> 10Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com>
11--- 11---
12 Makefile | 2 ++ 12 Makefile_G1G2 | 3 +++
13 decoder_sw/software/linux/dwl/dwl_linux.c | 2 +- 13 Makefile_H1 | 3 +++
14 2 files changed, 3 insertions(+), 1 deletion(-) 14 decoder_sw/software/linux/dwl/dwl_linux.c | 2 +-
15 h1_encoder/software/linux_reference/ewl/ewl_x280_common.c | 2 +-
16 4 files changed, 8 insertions(+), 2 deletions(-)
15 17
16Index: imx-vpu-hantro-1.7.0/decoder_sw/software/linux/dwl/dwl_linux.c 18diff --git a/Makefile_G1G2 b/Makefile_G1G2
17=================================================================== 19index caab40f..29866a4 100755
18--- imx-vpu-hantro-1.7.0.orig/decoder_sw/software/linux/dwl/dwl_linux.c 20--- a/Makefile_G1G2
19+++ imx-vpu-hantro-1.7.0/decoder_sw/software/linux/dwl/dwl_linux.c 21+++ b/Makefile_G1G2
22@@ -13,6 +13,9 @@ INCLUDE_HEADERS += -I$(SOURCE_ROOT)/linux/memalloc
23 #INCLUDE_HEADERS += -I$(SOURCE_ROOT)/linux/ldriver
24 INCLUDE_HEADERS += -I$(LINUX_KERNEL_ROOT)/include/uapi -I$(LINUX_KERNEL_ROOT)/include
25
26+# ION header location
27+INCLUDE_HEADERS += -I$(LINUX_KERNEL_ROOT)/drivers/staging/android/uapi
28+
29 CFLAGS += -DDEC_MODULE_PATH=\"/dev/mxc_hantro\" -DUSE_FAKE_RFC_TABLE -DFIFO_DATATYPE=void* -DNDEBUG -DDOWN_SCALER \
30 -DUSE_EXTERNAL_BUFFER -DUSE_FAST_EC -DUSE_VP9_EC -DGET_FREE_BUFFER_NON_BLOCK \
31 -DDEC_X170_OUTPUT_FORMAT=0 -DDEC_X170_TIMEOUT_LENGTH=-1 -DENABLE_HEVC_SUPPORT \
32diff --git a/Makefile_H1 b/Makefile_H1
33index 9ca1aa9..56b4332 100755
34--- a/Makefile_H1
35+++ b/Makefile_H1
36@@ -20,6 +20,9 @@ ENV += -DUSE_ION
37 ENV += -I$(LINUX_KERNEL_ROOT)/include/uapi -I$(LINUX_KERNEL_ROOT)/include
38 ENV += -I$(SDKTARGETSYSROOT)/usr/imx/include
39
40+# ION header location
41+ENV += -I$(LINUX_KERNEL_ROOT)/drivers/staging/android/uapi
42+
43 LIBENCNAME = libcodec_enc
44 LIBSENC = -L./ -lhantro_h1 -lpthread
45
46diff --git a/decoder_sw/software/linux/dwl/dwl_linux.c b/decoder_sw/software/linux/dwl/dwl_linux.c
47index 0899596..f2e1229 100755
48--- a/decoder_sw/software/linux/dwl/dwl_linux.c
49+++ b/decoder_sw/software/linux/dwl/dwl_linux.c
20@@ -41,7 +41,7 @@ 50@@ -41,7 +41,7 @@
21 #include "dwl.h" 51 #include "dwl.h"
22 #include <linux/hantrodec.h> 52 #include <linux/hantrodec.h>
23 #ifdef USE_ION 53 #ifdef USE_ION
24-#include <linux/ion.h> 54-#include <linux/ion.h>
25+#include <ion.h> 55+#include <ion.h>
56 #include <linux/dma-buf.h>
57 #include <linux/version.h>
26 #ifdef ANDROID 58 #ifdef ANDROID
27 #include <linux/mxc_ion.h> 59diff --git a/h1_encoder/software/linux_reference/ewl/ewl_x280_common.c b/h1_encoder/software/linux_reference/ewl/ewl_x280_common.c
28 #endif 60index 620c978..82b4836 100755
29Index: imx-vpu-hantro-1.7.0/Makefile_G1G2 61--- a/h1_encoder/software/linux_reference/ewl/ewl_x280_common.c
30=================================================================== 62+++ b/h1_encoder/software/linux_reference/ewl/ewl_x280_common.c
31--- imx-vpu-hantro-1.7.0.orig/Makefile_G1G2 63@@ -49,7 +49,7 @@
32+++ imx-vpu-hantro-1.7.0/Makefile_G1G2
33@@ -11,6 +11,8 @@ INCLUDE_HEADERS = -I./decoder_sw -I$(SOU
34 INCLUDE_HEADERS += -I$(SOURCE_ROOT)/linux/memalloc
35 #INCLUDE_HEADERS += -I$(SOURCE_ROOT)/linux/ldriver
36 INCLUDE_HEADERS += -I$(LINUX_KERNEL_ROOT)/include/uapi -I$(LINUX_KERNEL_ROOT)/include
37+# ION header location
38+INCLUDE_HEADERS += -I$(LINUX_KERNEL_ROOT)/drivers/staging/android/uapi
39 64
40 CFLAGS += -DDEC_MODULE_PATH=\"/dev/mxc_hantro\" -DUSE_FAKE_RFC_TABLE -DFIFO_DATATYPE=void* -DNDEBUG -DDOWN_SCALER \ 65 #include "linux/hx280enc.h"
41 -DUSE_EXTERNAL_BUFFER -DUSE_FAST_EC -DUSE_VP9_EC -DGET_FREE_BUFFER_NON_BLOCK \ 66 #ifdef USE_ION
67-#include <linux/ion.h>
68+#include <ion.h>
69 #include <linux/dma-buf.h>
70 #include <linux/version.h>
71 #ifdef ANDROID
72--
731.9.1
74
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.7.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.8.0.bb
index da2ac513..243f1f35 100644
--- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.7.0.bb
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.8.0.bb
@@ -2,9 +2,10 @@
2 2
3DESCRIPTION = "i.MX Hantro VPU library" 3DESCRIPTION = "i.MX Hantro VPU library"
4LICENSE = "Proprietary" 4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=ab61cab9599935bfe9f700405ef00f28" 5LIC_FILES_CHKSUM = "file://COPYING;md5=5ab1a30d0cd181e3408077727ea5a2db"
6 6
7DEPENDS = "virtual/kernel" 7DEPENDS = "virtual/kernel"
8do_configure[depends] += "virtual/kernel:do_shared_workdir"
8 9
9PROVIDES = "virtual/imxvpu" 10PROVIDES = "virtual/imxvpu"
10 11
@@ -12,13 +13,14 @@ SRC_URI = " \
12 ${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true \ 13 ${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true \
13 file://0001-Fix-ion.h-header-inclusion-to-be-standard.patch \ 14 file://0001-Fix-ion.h-header-inclusion-to-be-standard.patch \
14" 15"
15SRC_URI[md5sum] = "9a8ade25333e6ac3f7c345b71f3477a6" 16SRC_URI[md5sum] = "140796ddd6f1be47cffb7e5e2bfe0fb6"
16SRC_URI[sha256sum] = "a3bbf2d8ac00ecae6d48b05cb94d9bdf68085d5bfc54eb176e3bf59670a87ad1" 17SRC_URI[sha256sum] = "c092a5b0f8897bae54154f58e47b6d2de033da01ee231a8cd779a51bbe962606"
17 18
18inherit fsl-eula-unpack 19inherit fsl-eula-unpack
19 20
20PARALLEL_MAKE="-j 1" 21PARALLEL_MAKE="-j 1"
21 22
23PLATFORM_mx8mm = "IMX8MM"
22PLATFORM_mx8mq = "IMX8MQ" 24PLATFORM_mx8mq = "IMX8MQ"
23 25
24do_compile () { 26do_compile () {
@@ -32,4 +34,4 @@ do_install () {
32FILES_${PN} += "/unit_tests" 34FILES_${PN} += "/unit_tests"
33 35
34PACKAGE_ARCH = "${MACHINE_ARCH}" 36PACKAGE_ARCH = "${MACHINE_ARCH}"
35COMPATIBLE_MACHINE = "(mx8mq)" 37COMPATIBLE_MACHINE = "(mx8mq|mx8mm)"