diff options
author | Max Krummenacher <max.krummenacher@toradex.com> | 2022-11-21 13:37:00 +0100 |
---|---|---|
committer | Max Krummenacher <max.krummenacher@toradex.com> | 2022-11-25 11:59:26 +0100 |
commit | 0b45cf3f5bf95c583b189c2fb5eaa125bf686a7d (patch) | |
tree | cb3d8d0f61f61fc26a899d79e44ded8334351b2b /recipes-bsp/imx-vpu-hantro | |
parent | 143a9f756feea9cf6217f5d82a4811379d10b740 (diff) | |
download | meta-freescale-0b45cf3f5bf95c583b189c2fb5eaa125bf686a7d.tar.gz |
imx-vpu-hantro: prevent warning from oe qa
This passes among others -fdebug-prefix-map=... which prevents the
following OE warning:
| WARNING: imx-vpu-hantro-1.27.0-r0 do_package_qa: QA Issue: \
| File /usr/lib/.debug/libg1.so.1 in package imx-vpu-hantro-dbg contains reference to TMPDIR [buildpaths]
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp/imx-vpu-hantro')
-rw-r--r-- | recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-buildsystem-don-t-ignore-externally-set-cflags.patch | 49 | ||||
-rw-r--r-- | recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.27.0.bb | 5 |
2 files changed, 53 insertions, 1 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-buildsystem-don-t-ignore-externally-set-cflags.patch b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-buildsystem-don-t-ignore-externally-set-cflags.patch new file mode 100644 index 00000000..861230bb --- /dev/null +++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-buildsystem-don-t-ignore-externally-set-cflags.patch | |||
@@ -0,0 +1,49 @@ | |||
1 | From aba22ec2e285cf7557a5049fa6181e82e7f1a489 Mon Sep 17 00:00:00 2001 | ||
2 | From: Max Krummenacher <max.krummenacher@toradex.com> | ||
3 | Date: Mon, 21 Nov 2022 12:04:09 +0000 | ||
4 | Subject: [PATCH] buildsystem: don't ignore externally set cflags | ||
5 | |||
6 | Upstream-Status: pending | ||
7 | Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> | ||
8 | --- | ||
9 | decoder_sw/software/linux/h264high/Makefile | 4 ++-- | ||
10 | decoder_sw/software/linux/vp6/Makefile | 4 ++-- | ||
11 | 2 files changed, 4 insertions(+), 4 deletions(-) | ||
12 | |||
13 | diff --git a/decoder_sw/software/linux/h264high/Makefile b/decoder_sw/software/linux/h264high/Makefile | ||
14 | index 556ff71..7bdd99d 100755 | ||
15 | --- a/decoder_sw/software/linux/h264high/Makefile | ||
16 | +++ b/decoder_sw/software/linux/h264high/Makefile | ||
17 | @@ -50,10 +50,10 @@ CLEAR_HDRINFO_IN_SEEK = n | ||
18 | DEBUG = y | ||
19 | # Add your debugging flag (or not) to CFLAGS | ||
20 | ifeq ($(DEBUG),y) | ||
21 | - CFLAGS = $(M32) -g -O0 | ||
22 | + CFLAGS += $(M32) -g -O0 | ||
23 | DEBFLAGS = -DDEBUG -D_ASSERT_USED -D_RANGE_CHECK -D_ERROR_PRINT | ||
24 | else | ||
25 | - CFLAGS = $(M32) -O3 | ||
26 | + CFLAGS += $(M32) -O3 | ||
27 | DEBFLAGS = -DNDEBUG | ||
28 | endif | ||
29 | |||
30 | diff --git a/decoder_sw/software/linux/vp6/Makefile b/decoder_sw/software/linux/vp6/Makefile | ||
31 | index b6e6914..b933d46 100755 | ||
32 | --- a/decoder_sw/software/linux/vp6/Makefile | ||
33 | +++ b/decoder_sw/software/linux/vp6/Makefile | ||
34 | @@ -50,10 +50,10 @@ DEBUG = y | ||
35 | |||
36 | # Add your debugging flag (or not) to CFLAGS | ||
37 | ifeq ($(DEBUG),y) | ||
38 | - CFLAGS = -g -O0 | ||
39 | + CFLAGS += -g -O0 | ||
40 | DEBFLAGS = -DDEBUG -D_ASSERT_USED -D_ERROR_PRINT | ||
41 | else | ||
42 | - CFLAGS = -O3 | ||
43 | + CFLAGS += -O3 | ||
44 | DEBFLAGS = -DNDEBUG | ||
45 | endif | ||
46 | |||
47 | -- | ||
48 | 2.35.3 | ||
49 | |||
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.27.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.27.0.bb index 473d747c..35adecf8 100644 --- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.27.0.bb +++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.27.0.bb | |||
@@ -6,7 +6,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=5a0bf11f745e68024f37b4724a5364fe" | |||
6 | 6 | ||
7 | PROVIDES = "virtual/imxvpu" | 7 | PROVIDES = "virtual/imxvpu" |
8 | 8 | ||
9 | SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true" | 9 | SRC_URI = " \ |
10 | ${FSL_MIRROR}/${BP}.bin;fsl-eula=true \ | ||
11 | file://0001-buildsystem-don-t-ignore-externally-set-cflags.patch \ | ||
12 | " | ||
10 | SRC_URI[md5sum] = "cfa0e92da0eca9cf622c4d7abc618cef" | 13 | SRC_URI[md5sum] = "cfa0e92da0eca9cf622c4d7abc618cef" |
11 | SRC_URI[sha256sum] = "7e9bcdbd067ce66a1247373cbf088945346feb0027deb61af541ebc1256277c3" | 14 | SRC_URI[sha256sum] = "7e9bcdbd067ce66a1247373cbf088945346feb0027deb61af541ebc1256277c3" |
12 | 15 | ||