summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu-hantro
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2021-09-11 15:54:34 -0300
committerGitHub <noreply@github.com>2021-09-11 15:54:34 -0300
commit16e0d07d36787d14e9d00ff8123419863d1f19d2 (patch)
tree36a413f5702cd2d29b5023ec0762b71c27e4fac3 /recipes-bsp/imx-vpu-hantro
parent25e9cbddbd32802634bafef62ba08da9821c604d (diff)
parentb821d72e7b7fc250eb80fa43a79ce31b88863239 (diff)
downloadmeta-freescale-16e0d07d36787d14e9d00ff8123419863d1f19d2.tar.gz
Merge pull request #859 from angolini/hardknott+bsp
Backport NXP BSP 5.10.35_2.0.0 to Hardknott
Diffstat (limited to 'recipes-bsp/imx-vpu-hantro')
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon/0001-Makefile-Honor-LDFLAGS-from-toolchain.patch33
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.0.0.bb32
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-decoder_sw-resolve-compilation-error-with-fcommon.patch54
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.20.0.bb35
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.22.0.bb35
5 files changed, 100 insertions, 89 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon/0001-Makefile-Honor-LDFLAGS-from-toolchain.patch b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon/0001-Makefile-Honor-LDFLAGS-from-toolchain.patch
new file mode 100644
index 00000000..dff2fb8f
--- /dev/null
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon/0001-Makefile-Honor-LDFLAGS-from-toolchain.patch
@@ -0,0 +1,33 @@
1From 94ae72948f1ed1a8bad1c13b4edc4b9189207e35 Mon Sep 17 00:00:00 2001
2From: Tom Hochstein <tom.hochstein@nxp.com>
3Date: Mon, 26 Jul 2021 09:06:26 -0500
4Subject: [PATCH] Makefile: Honor LDFLAGS from toolchain
5
6The LDFLAGS variable is standard from the toolchain and should be
7honored. Yocto detects the problem with a QA check:
8
9ERROR: imx-vpu-hantro-daemon-1.1.0-r0 do_package_qa: QA Issue: File /usr/bin/vsidaemon in package imx-vpu-hantro-daemon doesn't have GNU_HASH (didn't pass LDFLAGS?) [ldflags]
10
11Upstream-Status: Pending
12
13Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
14---
15 Makefile | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/Makefile b/Makefile
19index 9a775b0..e73ff47 100755
20--- a/Makefile
21+++ b/Makefile
22@@ -22,7 +22,7 @@ OUT_FILE = vsidaemon
23 DEC = nxp_enc_hw
24 ENC = nxp_dec_hw
25 LIBFILES =
26-LD_FLAGS = -lpthread -lm
27+LD_FLAGS = $(LDFLAGS) -lpthread -lm
28
29 PLATFORM ?= IMX8MP
30
31--
322.17.1
33
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.0.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.0.0.bb
new file mode 100644
index 00000000..88b9ee0e
--- /dev/null
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.0.0.bb
@@ -0,0 +1,32 @@
1# Copyright 2021 NXP
2DESCRIPTION = "i.MX Hantro V4L2 Daemon"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cd8bc2a79509c22fc9c1782a151210b1"
5
6DEPENDS = "imx-vpu-hantro"
7DEPENDS_append_mx8mp = " imx-vpu-hantro-vc"
8
9SRC_URI = " \
10 ${FSL_MIRROR}/${BP}.tar.gz \
11 file://0001-Makefile-Honor-LDFLAGS-from-toolchain.patch \
12"
13SRC_URI[md5sum] = "65417710ef22214523c37f50f34b6ab2"
14SRC_URI[sha256sum] = "897d174c4c0818f31012d8a60ed51fc83fdfc55fca2d2b0fc24a0db3e9f3b6e8"
15
16PLATFORM_mx8mm = "IMX8MM"
17PLATFORM_mx8mq = "IMX8MQ"
18PLATFORM_mx8mp = "IMX8MP"
19
20EXTRA_OEMAKE = " \
21 CROSS_COMPILE="${HOST_PREFIX}" \
22 SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" \
23 CTRLSW_HDRPATH="${STAGING_INCDIR}" \
24 PLATFORM="${PLATFORM}" \
25"
26
27do_install () {
28 oe_runmake install DEST_DIR="${D}"
29}
30
31PACKAGE_ARCH = "${MACHINE_SOCARCH}"
32COMPATIBLE_MACHINE = "(mx8mq|mx8mm|mx8mp)"
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-decoder_sw-resolve-compilation-error-with-fcommon.patch b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-decoder_sw-resolve-compilation-error-with-fcommon.patch
deleted file mode 100644
index 8d9610d5..00000000
--- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-decoder_sw-resolve-compilation-error-with-fcommon.patch
+++ /dev/null
@@ -1,54 +0,0 @@
1From 5bfb24738c47003fd04a86bfd5a49f8c6354ed23 Mon Sep 17 00:00:00 2001
2From: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
3Date: Fri, 28 Aug 2020 07:46:35 +0000
4Subject: [PATCH] decoder_sw: resolve compilation error with -fcommon
5
6-fcommon is enabled by default in gcc10 compiler, which results in
7following build errors:
8
9decoder_sw/software/source/inc/decapicommon.h:272: multiple definition
10of `DecPicCodingType'; decoder_sw/software/linux/dwl/dwl_linux.o:
11decoder_sw/software/source/inc/decapicommon.h:272: first defined here
12
13decoder_sw/software/source/inc/dwl.h:94: multiple definition of
14`DWLInitParam'; decoder_sw/software/linux/dwl/dwl_linux.o:
15decoder_sw/software/source/inc/dwl.h:94: first defined here
16
17Drop multiple enum name definitions, which solves above compilation
18issues.
19
20Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
21---
22 decoder_sw/software/source/inc/decapicommon.h | 2 +-
23 decoder_sw/software/source/inc/dwl.h | 2 +-
24 2 files changed, 2 insertions(+), 2 deletions(-)
25
26diff --git a/decoder_sw/software/source/inc/decapicommon.h b/decoder_sw/software/source/inc/decapicommon.h
27index 0f02092..fc8cccf 100755
28--- a/decoder_sw/software/source/inc/decapicommon.h
29+++ b/decoder_sw/software/source/inc/decapicommon.h
30@@ -269,7 +269,7 @@ enum DecPicCodingType {
31 DEC_PIC_TYPE_D = 3,
32 DEC_PIC_TYPE_FI = 4,
33 DEC_PIC_TYPE_BI = 5
34-} DecPicCodingType;
35+};
36
37 /* Output picture pixel format types for raster scan or down scale output */
38 enum DecPicturePixelFormat {
39diff --git a/decoder_sw/software/source/inc/dwl.h b/decoder_sw/software/source/inc/dwl.h
40index 6991f03..fd357b3 100755
41--- a/decoder_sw/software/source/inc/dwl.h
42+++ b/decoder_sw/software/source/inc/dwl.h
43@@ -91,7 +91,7 @@ struct DWLLinearMem {
44 /* DWLInitParam is used to pass parameters when initializing the DWL */
45 struct DWLInitParam {
46 u32 client_type;
47-} DWLInitParam;
48+};
49
50 /* Hardware configuration description, same as in top API */
51 typedef struct DecHwConfig DWLHwConfig;
52--
532.17.1
54
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.20.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.20.0.bb
deleted file mode 100644
index b7c64cbb..00000000
--- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.20.0.bb
+++ /dev/null
@@ -1,35 +0,0 @@
1# Copyright (C) 2017-2020 NXP
2
3DESCRIPTION = "i.MX Hantro VPU library"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=cf3f9b8d09bc3926b1004ea71f7a248a"
6
7PROVIDES = "virtual/imxvpu"
8
9SRC_URI = " \
10 ${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true \
11"
12SRC_URI[md5sum] = "682b3a73bf5aa22a37d56a433d11fc91"
13SRC_URI[sha256sum] = "e6cdd5b4c628604906466fc9620e2b048cf1b2c863f9ee49616dd5212b9261b0"
14
15inherit fsl-eula-unpack use-imx-headers
16
17PARALLEL_MAKE="-j 1"
18
19PLATFORM_mx8mm = "IMX8MM"
20PLATFORM_mx8mq = "IMX8MQ"
21PLATFORM_mx8mp = "IMX8MP"
22
23do_compile () {
24 oe_runmake CROSS_COMPILE="${HOST_PREFIX}" \
25 SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" \
26 PLATFORM="${PLATFORM}" all
27}
28
29do_install () {
30 oe_runmake DEST_DIR="${D}" PLATFORM="${PLATFORM}" install
31}
32
33FILES_${PN} += "/unit_tests"
34
35COMPATIBLE_MACHINE = "(mx8mq|mx8mm|mx8mp)"
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.22.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.22.0.bb
new file mode 100644
index 00000000..20ac87c7
--- /dev/null
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.22.0.bb
@@ -0,0 +1,35 @@
1# Copyright (C) 2017-2020 NXP
2
3DESCRIPTION = "i.MX Hantro VPU library"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=417b82f17fc02b88125331ed312f6f1b"
6
7PROVIDES = "virtual/imxvpu"
8
9SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
10SRC_URI[md5sum] = "b65b49eadb6463b784e1a9e44a94fca1"
11SRC_URI[sha256sum] = "03c61dfb268b31a0d25a4d1387cb3ad0261029ad5de801f72224602e2b37da00"
12
13inherit fsl-eula-unpack use-imx-headers
14
15PARALLEL_MAKE="-j 1"
16
17PLATFORM_mx8mm = "IMX8MM"
18PLATFORM_mx8mq = "IMX8MQ"
19PLATFORM_mx8mp = "IMX8MP"
20
21EXTRA_OEMAKE = " \
22 CROSS_COMPILE="${HOST_PREFIX}" \
23 SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" \
24 PLATFORM="${PLATFORM}" \
25"
26
27do_install () {
28 oe_runmake install DEST_DIR="${D}"
29}
30
31FILES_${PN} += "/unit_tests"
32
33RDEPENDS_${PN} += "imx-vpu-hantro-daemon"
34
35COMPATIBLE_MACHINE = "(mx8mq|mx8mm|mx8mp)"