summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu-hantro
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-10-25 22:44:12 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2018-10-26 14:23:37 -0300
commitbc937ade566528cc097c9321694c0f5f5ef8cbf6 (patch)
treece4a1a56a5082f9c5f6d849963f5bbef4f993733 /recipes-bsp/imx-vpu-hantro
parent700abd5d1b9ce55de5c62a8d0a82c08aa6cd6897 (diff)
downloadmeta-freescale-bc937ade566528cc097c9321694c0f5f5ef8cbf6.tar.gz
classes/use-imx-headers: Easy linux-imx-headers use
This allow to easy reuse of binary packages among similar SoCs. The usual use for this is to share SoC specific packages among different boards independently of the kernel version it is using, as far it is ABI compatible with the official version it will just work. Following recipes has been reworked to make use of the class: - imx-lib - imx-test - imx-vpu-hantro - imx-vpu - imx-alsa-plugins - gstreamer1.0-plugins-base - gstreamer1.0-plugins-imx - imx-gst1.0-plugin Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp/imx-vpu-hantro')
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.8.0.bb5
1 files changed, 1 insertions, 4 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.8.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.8.0.bb
index 25ef41ed..c49f90db 100644
--- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.8.0.bb
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.8.0.bb
@@ -4,8 +4,6 @@ DESCRIPTION = "i.MX Hantro VPU library"
4LICENSE = "Proprietary" 4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=5ab1a30d0cd181e3408077727ea5a2db" 5LIC_FILES_CHKSUM = "file://COPYING;md5=5ab1a30d0cd181e3408077727ea5a2db"
6 6
7DEPENDS = "linux-imx-headers"
8
9PROVIDES = "virtual/imxvpu" 7PROVIDES = "virtual/imxvpu"
10 8
11SRC_URI = " \ 9SRC_URI = " \
@@ -15,7 +13,7 @@ SRC_URI = " \
15SRC_URI[md5sum] = "140796ddd6f1be47cffb7e5e2bfe0fb6" 13SRC_URI[md5sum] = "140796ddd6f1be47cffb7e5e2bfe0fb6"
16SRC_URI[sha256sum] = "c092a5b0f8897bae54154f58e47b6d2de033da01ee231a8cd779a51bbe962606" 14SRC_URI[sha256sum] = "c092a5b0f8897bae54154f58e47b6d2de033da01ee231a8cd779a51bbe962606"
17 15
18inherit fsl-eula-unpack 16inherit fsl-eula-unpack use-imx-headers
19 17
20PARALLEL_MAKE="-j 1" 18PARALLEL_MAKE="-j 1"
21 19
@@ -34,5 +32,4 @@ do_install () {
34 32
35FILES_${PN} += "/unit_tests" 33FILES_${PN} += "/unit_tests"
36 34
37PACKAGE_ARCH = "${MACHINE_ARCH}"
38COMPATIBLE_MACHINE = "(mx8mq|mx8mm)" 35COMPATIBLE_MACHINE = "(mx8mq|mx8mm)"