summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.25.0.bb
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-05-09 15:02:58 -0500
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2022-05-10 16:47:51 +0000
commiteb867a0e907eeb29058c4e46c8c9edf20764701a (patch)
tree8cc1ddf9919bf2ea39928d8cafe50d7f58cab9bd /recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.25.0.bb
parentc93841dd5c8cca04d1df581361d810bc74d72f2e (diff)
downloadmeta-freescale-eb867a0e907eeb29058c4e46c8c9edf20764701a.tar.gz
imx-vpu-hantro: Upgrade 1.24.0 -> 1.25.0
Fixes: 67cd762 M865SW-866 [VPU/H1] Potential risk during suspend/resume operation Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> (cherry picked from commit 496d5a1d3651b0bd9e75d16cbd871c5be69b2469)
Diffstat (limited to 'recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.25.0.bb')
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.25.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.25.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.25.0.bb
new file mode 100644
index 00000000..f2381d43
--- /dev/null
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.25.0.bb
@@ -0,0 +1,36 @@
1# Copyright (C) 2017-2020 NXP
2
3DESCRIPTION = "i.MX Hantro VPU library"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=be5ff43682ed6c57dfcbeb97651c2829"
6
7PROVIDES = "virtual/imxvpu"
8
9SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
10SRC_URI[md5sum] = "6d84b9eecc2f6027f9dbe1c875a4e7b5"
11SRC_URI[sha256sum] = "dd812b92b302bcfb92c10e937d9cad9224edf1593e9e4691d539ab4e190583f0"
12
13inherit fsl-eula-unpack use-imx-headers
14
15PARALLEL_MAKE="-j 1"
16
17PLATFORM:mx8mm-nxp-bsp = "IMX8MM"
18PLATFORM:mx8mq-nxp-bsp = "IMX8MQ"
19PLATFORM:mx8mp-nxp-bsp = "IMX8MP"
20
21EXTRA_OEMAKE = " \
22 CROSS_COMPILE="${HOST_PREFIX}" \
23 SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" \
24 PLATFORM="${PLATFORM}" \
25"
26
27do_install () {
28 oe_runmake install DEST_DIR="${D}"
29}
30
31FILES:${PN} += "/unit_tests"
32
33RDEPENDS:${PN} += "imx-vpu-hantro-daemon"
34
35PACKAGE_ARCH = "${MACHINE_SOCARCH}"
36COMPATIBLE_MACHINE = "(mx8mq-nxp-bsp|mx8mm-nxp-bsp|mx8mp-nxp-bsp)"