summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.23.0.bb
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-02-04 13:44:05 -0600
committerTom Hochstein <tom.hochstein@nxp.com>2022-02-04 13:45:41 -0600
commitdc573f7dd70e31ab90af30542d2da0a2fb651bc0 (patch)
treec0a0dca71a676dce24a3262223b2baa393db364c /recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.23.0.bb
parent598486537294c92511bfef627244cf1c972ebc08 (diff)
downloadmeta-freescale-dc573f7dd70e31ab90af30542d2da0a2fb651bc0.tar.gz
Revert "imx-vpu-hantro: Upgrade to 1.24.0"
The latest imx-vpu-hantro-daemon fails to download and has been reverted to the previous version, so revert this version as well. This reverts commit ddbc40ac9cb001f1e16da218a08f3a3a43b29dbb.
Diffstat (limited to 'recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.23.0.bb')
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.23.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.23.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.23.0.bb
new file mode 100644
index 00000000..427dbf92
--- /dev/null
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.23.0.bb
@@ -0,0 +1,35 @@
1# Copyright (C) 2017-2020 NXP
2
3DESCRIPTION = "i.MX Hantro VPU library"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa"
6
7PROVIDES = "virtual/imxvpu"
8
9SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
10SRC_URI[md5sum] = "3f8d4bb593d851d0523d0146131946ae"
11SRC_URI[sha256sum] = "a312a0b6d32ed16527e5bfcff362b231069428362ad5710f816bca019f70c6a2"
12
13inherit fsl-eula-unpack use-imx-headers
14
15PARALLEL_MAKE="-j 1"
16
17PLATFORM:mx8mm = "IMX8MM"
18PLATFORM:mx8mq = "IMX8MQ"
19PLATFORM:mx8mp = "IMX8MP"
20
21EXTRA_OEMAKE = " \
22 CROSS_COMPILE="${HOST_PREFIX}" \
23 SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" \
24 PLATFORM="${PLATFORM}" \
25"
26
27do_install () {
28 oe_runmake install DEST_DIR="${D}"
29}
30
31FILES:${PN} += "/unit_tests"
32
33RDEPENDS:${PN} += "imx-vpu-hantro-daemon"
34
35COMPATIBLE_MACHINE = "(mx8mq|mx8mm|mx8mp)"