diff options
author | Chris Dimich <Chris.Dimich@boundarydevices.com> | 2021-03-08 15:17:11 -0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2021-03-10 08:35:25 -0300 |
commit | 0a435d64e588843f6943d6e5723e5ecc12990aa2 (patch) | |
tree | e973f82fda07a37222b5388f1ba72a217c78eb6c /recipes-bsp/imx-vpu-hantro-vc | |
parent | 97d2ea43c86121c301360596a351a9cd5ea467fb (diff) | |
download | meta-freescale-0a435d64e588843f6943d6e5723e5ecc12990aa2.tar.gz |
imx-vpu-hantro-vc: add do_install function
The encoding library was not previously being installed.
Signed-off-by: Chris Dimich <Chris.Dimich@boundarydevices.com>
Diffstat (limited to 'recipes-bsp/imx-vpu-hantro-vc')
-rw-r--r-- | recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.3.0.bb | 19 |
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.3.0.bb b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.3.0.bb index 22f620fb..bd087898 100644 --- a/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.3.0.bb +++ b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.3.0.bb | |||
@@ -13,4 +13,23 @@ S = "${WORKDIR}/${BPN}-${PV}" | |||
13 | SRC_URI[md5sum] = "37c61718602ff08041b81319cfd6a8d9" | 13 | SRC_URI[md5sum] = "37c61718602ff08041b81319cfd6a8d9" |
14 | SRC_URI[sha256sum] = "8425796fc63d7107f2f57c51497281c4d54c883b2670817347fbe55f39dc2b8c" | 14 | SRC_URI[sha256sum] = "8425796fc63d7107f2f57c51497281c4d54c883b2670817347fbe55f39dc2b8c" |
15 | 15 | ||
16 | # SCR is the location and name of the Software Content Register file | ||
17 | # relative to ${D}${D_SUBDIR}. | ||
18 | SCR = "SCR.txt" | ||
19 | |||
20 | do_install () { | ||
21 | install -d ${D}${D_SUBDIR} | ||
22 | cp -r ${S}/* ${D}${D_SUBDIR} | ||
23 | if [ -d "${D}/usr/lib" ] && [ "${D}/usr/lib" != "${D}${libdir}" ]; then | ||
24 | mv ${D}/usr/lib ${D}${libdir} | ||
25 | fi | ||
26 | rm ${D}${D_SUBDIR}/COPYING | ||
27 | if [ ! -f ${D}${D_SUBDIR}/${SCR} ]; then | ||
28 | bbfatal "Missing Software Content Register \"${D}${D_SUBDIR}/${SCR}\"" | ||
29 | fi | ||
30 | rm ${D}${D_SUBDIR}/${SCR} | ||
31 | } | ||
32 | |||
33 | FILES_${PN} = "/" | ||
34 | |||
16 | COMPATIBLE_MACHINE = "(mx8mp)" | 35 | COMPATIBLE_MACHINE = "(mx8mp)" |