summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.8.0.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-08-18 08:22:46 -0300
committerGitHub <noreply@github.com>2022-08-18 08:22:46 -0300
commitba25d6659c5220970de523f938b0358bc11ae0ac (patch)
treee3aa70611355724e1924a99c16a55769fe7ffe88 /recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.8.0.bb
parent1d8ac870da885b0b2872d2448eec627edaf014fa (diff)
parent1f76bddcc9fdbb00b3293caac917a5ca85fe437b (diff)
downloadmeta-freescale-ba25d6659c5220970de523f938b0358bc11ae0ac.tar.gz
Merge pull request #1175 from Freescale/backport-1171-to-kirkstone
[Backport kirkstone] recipes-bsp: updates from NXP release 5.15.32-2.0.0
Diffstat (limited to 'recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.8.0.bb')
-rw-r--r--recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.8.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.8.0.bb b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.8.0.bb
new file mode 100644
index 00000000..dc5a0e5c
--- /dev/null
+++ b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.8.0.bb
@@ -0,0 +1,36 @@
1# Copyright (C) 2019-2021 NXP
2
3DESCRIPTION = "i.MX VC8000E Encoder library"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d3c315c6eaa43e07d8c130dc3a04a011"
6
7inherit fsl-eula-unpack
8
9SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
10
11S = "${WORKDIR}/${BPN}-${PV}"
12
13SRC_URI[md5sum] = "228b06302ad0f0da13a160573c06bbf4"
14SRC_URI[sha256sum] = "537fdbc20fbd1fb561b9a0d01ad843ea25c46e5a5cd184960fc9f1074674ddce"
15
16# SCR is the location and name of the Software Content Register file
17# relative to ${D}${D_SUBDIR}.
18SCR = "SCR.txt"
19
20do_install () {
21 install -d ${D}${D_SUBDIR}
22 cp -r ${S}/* ${D}${D_SUBDIR}
23 if [ -d "${D}/usr/lib" ] && [ "${D}/usr/lib" != "${D}${libdir}" ]; then
24 mv ${D}/usr/lib ${D}${libdir}
25 fi
26 rm ${D}${D_SUBDIR}/COPYING
27 if [ ! -f ${D}${D_SUBDIR}/${SCR} ]; then
28 bbfatal "Missing Software Content Register \"${D}${D_SUBDIR}/${SCR}\""
29 fi
30 rm ${D}${D_SUBDIR}/${SCR}
31}
32
33FILES:${PN} = "/"
34
35PACKAGE_ARCH = "${MACHINE_SOCARCH}"
36COMPATIBLE_MACHINE = "(mx8mp-nxp-bsp)"