summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.7.0.bb
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-05-09 15:17:18 -0500
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2022-05-10 16:47:51 +0000
commitbd64751ad41e1d67fc74551431eec6573c107fba (patch)
tree59c79940abe4de2c133b004ffc39a2abca0f11a5 /recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.7.0.bb
parente2a829cc9fbe8b1deb1ce3b2947fa4f30ad6037a (diff)
downloadmeta-freescale-bd64751ad41e1d67fc74551431eec6573c107fba.tar.gz
imx-vpu-hantro-vc: Upgrade 1.6.0 -> 1.7.0
Fixes: 4955219 Update library to latest commit 224712b M865SW-867 [VPU/VC800E] cma-heap memory leak due to not unmap it when close Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> (cherry picked from commit 6f318efe036ccd7815d65b2273562504b8a577cf)
Diffstat (limited to 'recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.7.0.bb')
-rw-r--r--recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.7.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.7.0.bb b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.7.0.bb
new file mode 100644
index 00000000..96c0c589
--- /dev/null
+++ b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.7.0.bb
@@ -0,0 +1,36 @@
1# Copyright (C) 2019-2021 NXP
2
3DESCRIPTION = "i.MX VC8000E Encoder library"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=be5ff43682ed6c57dfcbeb97651c2829"
6
7inherit fsl-eula-unpack
8
9SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
10
11S = "${WORKDIR}/${BPN}-${PV}"
12
13SRC_URI[md5sum] = "2dbcd9a71d53b86654704932798f263e"
14SRC_URI[sha256sum] = "8af665f8e06e0e467f563e372f43583d94128f0d37f75321965bc26bd4404b2b"
15
16# SCR is the location and name of the Software Content Register file
17# relative to ${D}${D_SUBDIR}.
18SCR = "SCR.txt"
19
20do_install () {
21 install -d ${D}${D_SUBDIR}
22 cp -r ${S}/* ${D}${D_SUBDIR}
23 if [ -d "${D}/usr/lib" ] && [ "${D}/usr/lib" != "${D}${libdir}" ]; then
24 mv ${D}/usr/lib ${D}${libdir}
25 fi
26 rm ${D}${D_SUBDIR}/COPYING
27 if [ ! -f ${D}${D_SUBDIR}/${SCR} ]; then
28 bbfatal "Missing Software Content Register \"${D}${D_SUBDIR}/${SCR}\""
29 fi
30 rm ${D}${D_SUBDIR}/${SCR}
31}
32
33FILES:${PN} = "/"
34
35PACKAGE_ARCH = "${MACHINE_SOCARCH}"
36COMPATIBLE_MACHINE = "(mx8mp-nxp-bsp)"