summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.5.0.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2021-11-01 08:30:54 -0300
committerGitHub <noreply@github.com>2021-11-01 08:30:54 -0300
commitd70a394ea52bbbbace83e613405db40f1be95f52 (patch)
treefabb396091127c4c6f3bd4a3b9b9c288528bf2fd /recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.5.0.bb
parent8616765308dbde2557b4770dfe34b90a19953a03 (diff)
parenta9ade478c9acbcef2b67aae376cac8254464dd6d (diff)
downloadmeta-freescale-d70a394ea52bbbbace83e613405db40f1be95f52.tar.gz
Merge pull request #899 from Freescale/backport-896-to-honister
[Backport honister] Upgrade to NXP Release: 5.10.52-2.1.0
Diffstat (limited to 'recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.5.0.bb')
-rw-r--r--recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.5.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.5.0.bb b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.5.0.bb
new file mode 100644
index 00000000..e6cffaca
--- /dev/null
+++ b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.5.0.bb
@@ -0,0 +1,35 @@
1# Copyright (C) 2019-2021 NXP
2
3DESCRIPTION = "i.MX VC8000E Encoder library"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa"
6
7inherit fsl-eula-unpack
8
9SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
10
11S = "${WORKDIR}/${BPN}-${PV}"
12
13SRC_URI[md5sum] = "fbd43a100c27abbae301428f1ae2bc64"
14SRC_URI[sha256sum] = "e59ac2ded726d722f61793b17fc394ce87b1c5710cb79f0b1d60b87fca5829e1"
15
16# SCR is the location and name of the Software Content Register file
17# relative to ${D}${D_SUBDIR}.
18SCR = "SCR.txt"
19
20do_install () {
21 install -d ${D}${D_SUBDIR}
22 cp -r ${S}/* ${D}${D_SUBDIR}
23 if [ -d "${D}/usr/lib" ] && [ "${D}/usr/lib" != "${D}${libdir}" ]; then
24 mv ${D}/usr/lib ${D}${libdir}
25 fi
26 rm ${D}${D_SUBDIR}/COPYING
27 if [ ! -f ${D}${D_SUBDIR}/${SCR} ]; then
28 bbfatal "Missing Software Content Register \"${D}${D_SUBDIR}/${SCR}\""
29 fi
30 rm ${D}${D_SUBDIR}/${SCR}
31}
32
33FILES:${PN} = "/"
34
35COMPATIBLE_MACHINE = "(mx8mp)"