summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.4.0.bb
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2021-07-23 09:51:39 -0500
committerDaiane Angolini <daiane.angolini@foundries.io>2021-09-11 13:35:14 -0300
commit123b1d5aefe914d19b34681d04a5c7d7bbbc6412 (patch)
tree4c54d62566e4648dbabfd0cfa63614e818f45c52 /recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.4.0.bb
parent1c20118ec1e95b86bee5b4e8e8c51a4d880a216d (diff)
downloadmeta-freescale-123b1d5aefe914d19b34681d04a5c7d7bbbc6412.tar.gz
imx-vpu-hantro-vc: Upgrade to 1.4.0
5d79111 MA-18966-5 [Android] video can't been play when use GKI image 9068e9d Merge yocto build workaround about linux version 3c75df3 Replace ion with dmabuf heaps for VC8000E ed4744a MA-18617 Rebuild vc8000e library for L5.10 Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.4.0.bb')
-rw-r--r--recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.4.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.4.0.bb b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.4.0.bb
new file mode 100644
index 00000000..58a140b4
--- /dev/null
+++ b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.4.0.bb
@@ -0,0 +1,35 @@
1# Copyright (C) 2019-2021 NXP
2
3DESCRIPTION = "i.MX VC8000E Encoder library"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=417b82f17fc02b88125331ed312f6f1b"
6
7inherit fsl-eula-unpack
8
9SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
10
11S = "${WORKDIR}/${BPN}-${PV}"
12
13SRC_URI[md5sum] = "b5270450ba2da5b7468b67ae8c0bcdca"
14SRC_URI[sha256sum] = "d5efae484c4271c098286d007590d6bf40c272d4f35702ff65625f2362715ab3"
15
16# SCR is the location and name of the Software Content Register file
17# relative to ${D}${D_SUBDIR}.
18SCR = "SCR.txt"
19
20do_install () {
21 install -d ${D}${D_SUBDIR}
22 cp -r ${S}/* ${D}${D_SUBDIR}
23 if [ -d "${D}/usr/lib" ] && [ "${D}/usr/lib" != "${D}${libdir}" ]; then
24 mv ${D}/usr/lib ${D}${libdir}
25 fi
26 rm ${D}${D_SUBDIR}/COPYING
27 if [ ! -f ${D}${D_SUBDIR}/${SCR} ]; then
28 bbfatal "Missing Software Content Register \"${D}${D_SUBDIR}/${SCR}\""
29 fi
30 rm ${D}${D_SUBDIR}/${SCR}
31}
32
33FILES_${PN} = "/"
34
35COMPATIBLE_MACHINE = "(mx8mp)"